wKioL1mABs2hdWSiAAFaiXzMXCQ498.png-wh_50



                           要求全网互通

R1:

[R1]interface e0/0/0

[R1-Ethernet0/0/0]ip ad

[R1-Ethernet0/0/0]ip address 12.1.1.1 24

[R1-Ethernet0/0/0]int loo 0

[R1-LoopBack0]ip address 172.16.1.1 32

[R1-LoopBack0]int loo 1

[R1-LoopBack1]ip address 172.16.1.2 32

[R1-LoopBack1]int loo 2

[R1-LoopBack2]ip address 172.16.1.3 32

RIP:

[R1]rip

[R1-rip-1]version 2

[R1-rip-1]undo summary (这个步骤是关闭自动汇总,如果不关闭,默认开启,自动汇总有时候是有缺陷的,最好关闭)

[R1-rip-1]network 172.16.0.0

[R1-rip-1]network 12.0.0.0


R2:

[R2]int e0/0

[R2-Ethernet0/0/0]ip address 12.1.1.2 24

[R2-Ethernet0/0/0]int e0/0/1

[R2-Ethernet0/0/1]ip address 23.1.1.2 24

[R2-Ethernet0/0/1]q

RIP:

[R2]rip

[R2-rip-1]version 2

[R2-rip-1]undo summary

[R2-rip-1]network 12.0.0.0

[R2-rip-1]network 23.0.0.0



R3:

[R3]int e0/0/0

[R3-Ethernet0/0/0]ip address 23.1.1.3 24

[R3-Ethernet0/0/0]q

RIP:

[R3]rip

[R3-rip-1]version 2

[R3-rip-1]undo summary

[R3-rip-1]network 23.0.0.0

[R3-rip-1]network 192.168.1.0

[R3-rip-1]q

[R3]int loo 0

[R3-LoopBack0]ip address 192.168.1..1 24


到此结束,任意节点ping任意节点都会通!