TCP/IP卷一实验之------路由过滤_路由实验
 
2 Configure a route filter at A in Figure 13-7 that will prevent D from learning about subnet 172.16.10.0/24.
 
3 Configure a route filter at A in Figure 13-7 that will allow only subnets 172.16.2.0/24, 172.16.8.0/24, and 172.16.9.0/24 to be advertised into the RIP domain.
 
4 Configure a route filter at A in Figure 13-7 that will prevent B from learning about any of the subnets in the RIP domain.
 
5 OSPFv3 for IPv6 is added to Routers A, B and C. RIPng is added to Routers A, D, and E. IPv6 prefixes 2001:db8:0:1::/64, 2001:db8:0:2::/64, and 2001:db8:0:3::/64 are connected to Router B. Prefixes 2001:db8:0:a::/64, 2001:db8:0:b::/64, and 2001:db8:0:c::/64 are connected to Router E. Configure a route filter at A in Figure 13-7 that prevents the prefixes 2001:db8:0:a::/64 and 2001:db8:0:b::/64 from being advertised to D.
 
 
A
conf t
ipv6 unicast-routing
int s2/0
encap f
no arp f
no shut
int s2/0.2 point-to-point
ip ad 172.16.254.1 255.255.255.0
frame interface-dlci 102
ipv6 ad 2001:db8:0:1e::1/64
ipv6 ospf 1 area 0
int s2/0.3 point-to-point
ip ad 172.16.253.1 255.255.255.0
frame interface-dlci 103
int s2/0.4 point-to-point
ip ad 172.16.252.1 255.255.255.0
frame interface-dlci 104
int s2/0.5 point-to-point
ip ad 172.16.251.1 255.255.255.0
frame interface-dlci 105
ipv6 ad 2001:db8:0:1b::1/64
ipv6 rip cisco enable
exit
access-list 1 deny 172.16.10.0 0.0.0.255
access-list 1 permit any
access-list 2 permit 172.16.2.0 0.0.0.255
access-list 2 permit 172.16.8.0 0.0.0.255
access-list 2 permit 172.16.9.0 0.0.0.255
access-list 3 deny 172.16.4.0 0.0.0.255
access-list 3 deny 172.16.5.0 0.0.0.255
access-list 3 deny 172.16.6.0 0.0.0.255
access-list 3 deny 172.16.10.0 0.0.0.255
access-list 3 deny 172.16.11.0 0.0.0.255
access-list 3 deny 172.16.12.0 0.0.0.255
access-list 3 permit any
ipv6 prefix-list DENY_D seq 5 deny 2001:DB8:0:A::/63 le 64
ipv6 prefix-list DENY_D seq 10 permit ::/0 le 128
route-map DENY_B
match ip address 3
route-map PERMIT_RIP 10
match ip address 1
router rip
ver 2
no au
passive-interface s2/0.2
passive-interface s2/0.3
net 172.16.0.0
distribute-list 1 out  s2/0.2
redistribute eigrp 100 metric 5 route-map PERMIT_RIP
exit
ipv6 router rip cisco
distribute-list prefix-list DENY_D out  s2/0.4
exit
router eigrp 100
no au
net 172.16.254.0 0.0.0.255
net 172.16.253.0 0.0.0.255
net 172.16.252.0 0.0.0.255
net 172.16.251.0 0.0.0.255
redistribute rip metric 10000 100 255 1 1500 route-map DENY_B
exit
ipv6 router ospf 1
end
 
 
B
conf t
ipv6 unicast-routing
int l 0
ip ad 172.16.1.2 255.255.255.0
ipv6 ad 2001:db8:0:1::2/64
ipv6 ospf  1 area 0
int l 1
ip ad 172.16.2.2 255.255.255.0
ipv6 ad 2001:db8:0:2::2/64
ipv6 ospf 1 area 0
int l 2
ip ad 172.16.3.2 255.255.255.0
ipv6 ad 2001:db8:0:3::2/64
ipv6 ospf 1 area 0
int s2/0
encap  f
no arp f
no shut
int s2/0.2 point-to-point
ip ad 172.16.254.2 255.255.255.0
frame interface-dlci 201
ipv6 ad 2001:db8:0:1e::2/64
router eigrp 100
no au
net 172.16.1.0 0.0.0.255
net 172.16.2.0 0.0.0.255
net 172.16.3.0 0.0.0.255
net 172.16.254.0 0.0.0.255
ipv6 router ospf 1
end
 
 
C
conf t
ipv6 unicast-routing
int l 0
ip ad 172.16.7.3 255.255.255.0
int l 1
ip ad 172.16.8.3 255.255.255.0
int l 2
ip ad 172.16.9.3 255.255.255.0
int s 2/0
encap f
no arp f
no shut
int s 2/0.3 point-to-point
ip ad 172.16.253.3 255.255.255.0
frame interface-dlci 301
ipv6 ospf 1 area 0
exit
ipv6 router ospf 1
exit
router eigrp 100
no au
net 172.16.7.0 0.0.0.255
net 172.16.8.0 0.0.0.255
net 172.16.9.0 0.0.0.255
net 172.16.253.0 0.0.0.255
end
 
 
D
conf t
ipv6 unicast-routing
int l 0
ip ad 172.16.4.4 255.255.255.0
int l 1
ip ad 172.16.5.4 255.255.255.0
int l 2
ip ad 172.16.6.4 255.255.255.0
int s 2/0
encap f
no arp f
no shut
int s2/0.4 point-to-point
ip ad 172.16.252.4 255.255.255.0
frame interface-dlci 401
ipv6 rip cisco enable
exit
ipv6 router rip cisco
router rip
ver 2
no au
net 172.16.0.0
end
 
 
E
conf t
ipv6 unicast-routing
int l 0
ip ad 172.16.10.5 255.255.255.0
ipv6 ad 2001:db8:0:a::5/64
ipv6 rip cisco enable
int l 1
ip ad 172.16.11.5 255.255.255.0
ipv6 ad 2001:db8:0:b::5/64
ipv6 rip cisco enable
int l 2
ip ad 172.16.12.5 255.255.255.0
ipv6 ad 2001:db8:0:c::5/64
ipv6 rip cisco enable
int s2/0
encap f
no arp f
no shut
int s2/0.5 point-to-point
ip ad 172.16.251.5 255.255.255.0
frame interface-dlci 501
ipv6 ad 2001:db8:0:1b::5/64
ipv6 rip cisco enable
router rip
ver 2
no au
net 172.16.0.0
exit
ipv6 router rip cisco
end