CCNA(高级实验)_高级实验
 
以下是我个的人解法,如果有错误请指正!
R4的配置:
R4#sh run
Building configuration...
Current configuration : 1055 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!
interface Loopback1
 ip address 172.16.2.1 255.255.255.0
!
interface Loopback2
 ip address 172.16.3.1 255.255.255.0
!        
interface Serial0/0
 ip address 192.168.14.4 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!
interface Serial0/1
 no ip address
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 100
 network 172.16.1.1 0.0.0.0
 network 172.16.2.1 0.0.0.0
 network 172.16.3.1 0.0.0.0
 network 192.168.14.4 0.0.0.0
 no auto-summary
!
ip http server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end
 
R2的配置:
R2#sh run
Building configuration...
Current configuration : 1424 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!        
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Serial0/0
 ip address 192.168.14.1 255.255.255.0
 ip access-group 100 in
 serial restart-delay 0
!
interface Serial0/1
 ip address 8.8.13.1 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!        
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 100
 redistribute ospf 100 metric 64000 100 100 200 1500
 network 192.168.14.1 0.0.0.0
 no auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 100 subnets
 network 8.8.13.0 0.0.0.255 area 0
!
ip http server
!
!        
!
access-list 100 deny   tcp 172.16.0.0 0.0.255.255 host 8.8.13.3 eq telnet
access-list 100 deny   icmp 172.16.0.0 0.0.255.255 host 8.8.3.3 echo
access-list 100 deny   tcp 172.16.0.0 0.0.255.255 host 8.8.35.3 eq telnet
access-list 100 deny   icmp 172.16.0.0 0.0.255.255 host 8.8.35.5 echo
access-list 100 deny   icmp 172.16.0.0 0.0.255.255 host 8.8.5.5 echo
access-list 100 permit tcp any any
access-list 100 permit ip any any
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end
R2#
R1的配置:
R1#sh run
Building configuration...
Current configuration : 1215 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$ew3O$QEnugiNV7MNW8gTRzNfIT/
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 8.8.3.3 255.255.255.0
 ip ospf network point-to-point
!
interface Serial0/0
 ip address 8.8.13.3 255.255.255.0
 serial restart-delay 0
!        
interface Serial0/1
 ip address 8.8.35.3 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 255
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 8.8.35.5 105 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 log-adjacency-changes
 network 8.8.3.0 0.0.0.255 area 0
 network 8.8.13.0 0.0.0.255 area 0
 network 8.8.35.0 0.0.0.255 area 0
 neighbor 8.8.35.5
!
ip http server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 password cisco
 login
!
!
end
R1#
R5的配置:
R5#sh run
Building configuration...
Current configuration : 1104 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!        
!
!
!
!
!
!
!
!
!
!
username cisco password 0 cisco
!
!
!
!
interface Loopback0
 ip address 8.8.5.5 255.255.255.0
 ip ospf network point-to-point
!
interface Serial0/0
 ip address 8.8.35.5 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 serial restart-delay 0
 frame-relay map ip 8.8.35.3 501 broadcast
 frame-relay lmi-type ansi
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 100
 log-adjacency-changes
 network 8.8.5.0 0.0.0.255 area 0
 network 8.8.35.0 0.0.0.255 area 0
!
ip http server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login local
line vty 5 871
 login local
!
!
end
R5#