ISP1#show run
!
interface Loopback0
 ip address 10.0.1.2 255.255.255.252
!
interface Serial1/1
 ip address 10.0.0.5 255.255.255.252 
 no sh
!
ip classless
ip route 42.0.0.48 255.255.255.240 10.0.0.6
san1#show run
!
interface FastEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 ip nat inside 
 no sh
!
interface Serial1/0
 ip address 10.0.0.6 255.255.255.252
 ip nat outside
 no sh
!
ip nat translation timeout 10
ip nat pool mynatpool 42.0.0.55 42.0.0.62 netmask 255.255.255.240
ip nat inside source list 2 pool mynatpool
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.5
no ip http server
!
!
access-list 2 permit 192.168.0.0 0.0.0.255
!
!
PC1#show run
!
interface FastEthernet0/0
 ip address 192.168.0.20 255.255.255.0
!
ip default-gateway 192.168.0.1
!no ip routing
PC2#show run
!
!
interface FastEthernet0/0
 ip address 192.168.0.5 255.255.255.0
!
ip default-gateway 192.168.0.1
no ip routing
!