Number Steps



Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4159    Accepted Submission(s): 2513


Problem Description

Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.


HDU1931_Number Steps【水题】_等差数列


You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

 

Input

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

 

Output

For each point in the input, write the number written at that point or write No Number if there is none.

 

Sample Input

3

4 2

6 6

3 4


Sample Output

6

12

No Number


Source


Asia 2000, Tehran (Iran)


题目大意:按照如图所示的规律和顺序给平面描点,给你坐标(x,y),判断(x,y)

上是否有点,若有点,输出该点的值是多少。若没有点,则输出No Number。

思路:可以看做是值为0,1,2,3的点组成的平行四边形的平移,或是递推得到。可看

出0,1,2,3分别平移能得到4个差值为4的等差数列,只需判断点是否在这两条直线上,

然后通过总结出的等差数列的公式计算出该点的值就行了



#include<stdio.h>
#include<string.h>

int main()
{
int T,x,y;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&x,&y);
if(x==y && x>=0)
{
if(x&1)
printf("%d\n",2*x-1);
else
printf("%d\n",2*x);
}
else if(y==x-2 && x>=2 && y>=0)
{
if(x&1)
printf("%d\n",2*x-3);
else
printf("%d\n",2*x-2);
}
else
printf("No Number\n");
}

return 0;
}