Dirichlet's Theorem on Arithmetic Progressions


Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 14514

 

Accepted: 7273


Description


If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., aa + da + 2da + 3da + 4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet (1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers ad, and n.


Input


The input is a sequence of datasets. A dataset is a line containing three positive integers ad, and n separated by a space. a and d are relatively prime. You may assumea <= 9307, d <= 346, and n <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.


Output


The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset adn should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.


Sample Input


367 186 151 179 10 203 271 37 39 103 230 1 27 104 185 253 50 85 1 1 1 9075 337 210 307 24 79 331 221 177 259 170 40 269 58 102 0 0 0


Sample Output


92809 6709 12037 103 93523 14503 2 899429 5107 412717 22699 25673


Source


​Japan 2006 Domestic​



# include<stdio.h>
# include<string.h>
int prime[1000000];

void isprimer()
{
int i,j;
memset(prime,0,sizeof(prime));
for(i=2;i<=1000000;i++)
if(prime[i]==0)
for(j=2*i;j<=1000000;j+=i)
prime[j] = 1;
prime[1] = prime[0] = 1;
}

int main()
{
int a,d,n,i;
isprimer();
while(scanf("%d %d %d",&a,&d,&n) && a!=0 || d!=0 || n!=0)
{
for(i=a;;i+=d)
if(prime[i]==0)
{
n--;
if(n==0)
{
printf("%d\n",i);
break;
}
}
}

return 0;
}