cigarettes



3000 ms  |  内存限制: 65535



2



Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette. 
Now,do you know how many cigarettes can Tom has?



First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k. 输出 For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have. 样例输入

3 4 3 10 3 100 5

样例输出

5 14 124

# include<stdio.h>

int main()
{
int n,a,b,k;
scanf("%d",&n);
while(n--)
{
scanf("%d %d",&a,&k);
b = a;
while(b/k!=0)
{
a = a + b/k;
b = b/k + b%k;
}
printf("%d\n",a);
}

return 0;
}