EIGRP 手工汇总_手工汇总
 
R1 配置
router>en
router#conf t
router(config)#host r1
r1(config)#ena sec 123
r1(config)#no ip domain-lookup
r1(config)#ban mot #Welcome to r1#
r1(config)#line vty 0 4
r1(config-line)#no login
r1(config-line)#line con 0
r1(config-line)#no exe-ctime
r1(config-line)#int lo0
r1(config-if)#ip add 10.1.1.1 255.255.255.0
r1(config-if)#int lo1
r1(config-if)#ip add 10.2.2.1 255.255.255.0
r1(config-if)#int s1/0
r1(config-if)#clock rate 64000
r1(config-if)#ip add 192.168.1.1 255.255.255.0
r1(config-if)#ip summary-add eigrp 1 10.0.0.0 255.252.0.0
r1(config-if)#no shut
r1(config-if)#router eigrp 1
r1(config-router)#net 10.1.1.0 0.0.0.255
r1(config-router)#net 10.2.2.0 0.0.0.255
r1(config-router)#net 192.168.1.0 0.0.0.255
r1(config-router)#no auto-summary
r1(config-router)#end
r1#
R2 配置
router>en
router#conf t
router(config)#host r2
r2(config)#ena sec 123
r2(config)#no ip domain-lookup
r2(config)#ban mot #Welcome to r2#
r2(config)#line vty 0 4
r2(config-line)#no login
r2(config-line)#line con 0
r2(config-line)#no exec-time
r2(config-line)#int lo0
r2(config-if)#ip add 172.16.1.1 255.255.255.0
r2(config-if)#int lo1
r2(config-if)#ip add 172.16.2.1 255.255.255.0
r2(config-if)#int s1/0
r2(config-if)#ip add 192.168.1.2 255.255.255.0
r2(config-if)#ip summary-add eigrp 1 172.16.0.0 255.255.252.0
r2(config-if)#no shut
r2(config-if)#router eigrp 1
r2(config-router)#net 172.16.1.0 0.0.0.255
r2(config-router)#net 172.16.2.0 0.0.0.255
r2(config-router)#net 192.168.1.0 0.0.0.255
r2(config-router)#no auto-summary
r2(config-router)#end
r2#
Welcome to r1
r1>en
Password:
r1#show run
Building configuration...
Current configuration : 1155 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$YgdT$Alx6PtFFkNr5rJ3h5MCnj/
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.2.2.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface Serial1/0
 clock rate 64000
 ip address 192.168.1.1 255.255.255.0
 ip summary-address eigrp 1 10.0.0.0 255.252.0.0 5
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 10.1.1.0 0.0.0.255
 network 10.2.2.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r1^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end
r1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     172.16.0.0/22 is subnetted, 1 subnets
D       172.16.0.0 [90/2297856] via 192.168.1.2, 00:02:03, Serial1/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.2.2.0/24 is directly connected, Loopback1
C       10.1.1.0/24 is directly connected, Loopback0
D       10.0.0.0/14 is a summary, 00:02:08, Null0
C    192.168.1.0/24 is directly connected, Serial1/0
r1#192.168.1.2
Trying 192.168.1.2 ... Open
Welcome to r2
r2>en
Password:
r2#show run
Building configuration...
Current configuration : 1167 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Dttt$EWqynNrt/8HD4URLoH.lR/
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!
interface Loopback1
 ip address 172.16.2.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface Serial1/0
 ip address 192.168.1.2 255.255.255.0
 ip summary-address eigrp 1 172.16.0.0 255.255.252.0 5
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 172.16.1.0 0.0.0.255
 network 172.16.2.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r2^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end
r2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.0.0/22 is a summary, 00:04:40, Null0
C       172.16.1.0/24 is directly connected, Loopback0
C       172.16.2.0/24 is directly connected, Loopback1
     10.0.0.0/14 is subnetted, 1 subnets
D       10.0.0.0 [90/2297856] via 192.168.1.1, 00:02:28, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0
r2#