R1#show run
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Serial1/0
ip address 18.0.0.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 12.0.0.1 255.255.255.0
serial restart-delay 0
!
interface FastEthernet2/0
ip address 17.0.0.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
redistribute connected subnets
redistribute bgp 1 subnets
network 1.1.1.0 0.0.0.255 area 0
network 17.0.0.0 0.0.0.255 area 0
network 18.0.0.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor song peer-group
neighbor song remote-as 1
neighbor song update-source Loopback0
neighbor song next-hop-self
neighbor 4.4.4.4 peer-group song
neighbor 12.0.0.2 remote-as 2
no auto-summary
!
line con 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end
R1#sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
17.0.0.0/24 is subnetted, 1 subnets
C 17.0.0.0 is directly connected, FastEthernet2/0
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
B 2.2.2.0 [20/0] via 12.0.0.2, 01:53:57
48.0.0.0/24 is subnetted, 1 subnets
O 48.0.0.0 [110/66] via 17.0.0.7, 00:34:45, FastEthernet2/0
18.0.0.0/24 is subnetted, 1 subnets
C 18.0.0.0 is directly connected, Serial1/0
4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O 4.4.4.4/32 [110/3] via 17.0.0.7, 00:34:45, FastEthernet2/0
B 4.4.4.0/24 [200/0] via 4.4.4.4, 00:32:06
5.0.0.0/24 is subnetted, 1 subnets
O E2 5.5.5.0 [110/1] via 17.0.0.7, 00:34:46, FastEthernet2/0
6.0.0.0/24 is subnetted, 1 subnets
O E2 6.6.6.0 [110/1] via 17.0.0.7, 00:34:46, FastEthernet2/0
7.0.0.0/32 is subnetted, 1 subnets
O 7.7.7.7 [110/2] via 17.0.0.7, 00:34:46, FastEthernet2/0
8.0.0.0/32 is subnetted, 1 subnets
O 8.8.8.8 [110/65] via 18.0.0.8, 00:34:46, Serial1/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.0.0.0 is directly connected, Serial1/1
47.0.0.0/24 is subnetted, 1 subnets
O 47.0.0.0 [110/2] via 17.0.0.7, 00:34:46, FastEthernet2/0
45.0.0.0/24 is subnetted, 1 subnets
O E2 45.0.0.0 [110/20] via 17.0.0.7, 00:06:35, FastEthernet2/0
R1#sh ip bgp
BGP table version is 28, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
r>i1.1.1.1/32 4.4.4.4 3 100 0 ?
*> 2.2.2.0/24 12.0.0.2 0 0 2 i
*>i4.4.4.0/24 4.4.4.4 0 100 0 i
r>i5.5.5.0/24 4.4.4.4 0 100 0 5 i
r>i6.6.6.0/24 4.4.4.4 0 100 0 5 i
r>i7.7.7.7/32 4.4.4.4 2 100 0 ?
r>i8.8.8.8/32 4.4.4.4 65 100 0 ?
r> 12.0.0.0/24 12.0.0.2 0 0 2 ?
r>i17.0.0.0/24 4.4.4.4 2 100 0 ?
r>i18.0.0.0/24 4.4.4.4 66 100 0 ?
r>i45.0.0.0/24 4.4.4.4 0 100 0 5 ?
r>i47.0.0.0/24 4.4.4.4 0 100 0 ?
r>i48.0.0.0/24 4.4.4.4 0 100 0 ?
R1#
------------------------------------------------------------------------------------------------------------------------
R2#sh run
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Serial1/0
ip address 12.0.0.2 255.255.255.0
serial restart-delay 0
!
router bgp 2
no synchronization
bgp log-neighbor-changes
network 2.2.2.0 mask 255.255.255.0
redistribute connected
neighbor 12.0.0.1 remote-as 1
no auto-summary
!
line con 0
logging synchronous
stopbits 1
end
R2#sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
17.0.0.0/24 is subnetted, 1 subnets
B 17.0.0.0 [20/0] via 12.0.0.1, 00:33:27
1.0.0.0/32 is subnetted, 1 subnets
B 1.1.1.1 [20/0] via 12.0.0.1, 00:33:27
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
48.0.0.0/24 is subnetted, 1 subnets
B 48.0.0.0 [20/0] via 12.0.0.1, 00:33:27
18.0.0.0/24 is subnetted, 1 subnets
B 18.0.0.0 [20/0] via 12.0.0.1, 00:33:27
4.0.0.0/24 is subnetted, 1 subnets
B 4.4.4.0 [20/0] via 12.0.0.1, 00:34:15
5.0.0.0/24 is subnetted, 1 subnets
B 5.5.5.0 [20/0] via 12.0.0.1, 00:44:57
6.0.0.0/24 is subnetted, 1 subnets
B 6.6.6.0 [20/0] via 12.0.0.1, 00:44:57
7.0.0.0/32 is subnetted, 1 subnets
B 7.7.7.7 [20/0] via 12.0.0.1, 00:33:27
8.0.0.0/32 is subnetted, 1 subnets
B 8.8.8.8 [20/0] via 12.0.0.1, 00:33:27
12.0.0.0/24 is subnetted, 1 subnets
C 12.0.0.0 is directly connected, Serial1/0
47.0.0.0/24 is subnetted, 1 subnets
B 47.0.0.0 [20/0] via 12.0.0.1, 00:33:27
45.0.0.0/24 is subnetted, 1 subnets
B 45.0.0.0 [20/0] via 12.0.0.1, 00:30:26
R2#sh ip bgp
BGP table version is 14, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 12.0.0.1 0 1 ?
*> 2.2.2.0/24 0.0.0.0 0 32768 i
*> 4.4.4.0/24 12.0.0.1 0 1 i
*> 5.5.5.0/24 12.0.0.1 0 1 5 i
*> 6.6.6.0/24 12.0.0.1 0 1 5 i
*> 7.7.7.7/32 12.0.0.1 0 1 ?
*> 8.8.8.8/32 12.0.0.1 0 1 ?
*> 12.0.0.0/24 0.0.0.0 0 32768 ?
*> 17.0.0.0/24 12.0.0.1 0 1 ?
*> 18.0.0.0/24 12.0.0.1 0 1 ?
*> 45.0.0.0/24 12.0.0.1 0 1 5 ?
*> 47.0.0.0/24 12.0.0.1 0 1 ?
*> 48.0.0.0/24 12.0.0.1 0 1 ?
------------------------------------------------------------------------------------------------------------------------
R4#sh run
interface Loopback0
ip address 4.4.4.4 255.255.255.0
!
interface Serial1/0
ip address 48.0.0.4 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 45.0.0.4 255.255.255.0
serial restart-delay 0
!
interface FastEthernet2/0
ip address 47.0.0.4 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
redistribute connected subnets
redistribute bgp 1 subnets
network 4.4.4.0 0.0.0.255 area 0
network 47.0.0.0 0.0.0.255 area 0
network 48.0.0.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
network 4.4.4.0 mask 255.255.255.0
redistribute ospf 1
neighbor IBGP peer-group
neighbor IBGP remote-as 1
neighbor IBGP update-source Loopback0
neighbor IBGP next-hop-self
neighbor 1.1.1.1 peer-group IBGP
neighbor 45.0.0.5 remote-as 5
no auto-summary
!
line con 0
logging synchronous
stopbits 1
end
R4#show ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
17.0.0.0/24 is subnetted, 1 subnets
O 17.0.0.0 [110/2] via 47.0.0.7, 00:38:07, FastEthernet2/0
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/3] via 47.0.0.7, 00:38:07, FastEthernet2/0
2.0.0.0/24 is subnetted, 1 subnets
O E2 2.2.2.0 [110/1] via 47.0.0.7, 00:38:07, FastEthernet2/0
48.0.0.0/24 is subnetted, 1 subnets
C 48.0.0.0 is directly connected, Serial1/0
18.0.0.0/24 is subnetted, 1 subnets
O 18.0.0.0 [110/66] via 47.0.0.7, 00:38:07, FastEthernet2/0
4.0.0.0/24 is subnetted, 1 subnets
C 4.4.4.0 is directly connected, Loopback0
5.0.0.0/24 is subnetted, 1 subnets
B 5.5.5.0 [20/0] via 45.0.0.5, 01:20:24
6.0.0.0/24 is subnetted, 1 subnets
B 6.6.6.0 [20/0] via 45.0.0.5, 01:20:24
7.0.0.0/32 is subnetted, 1 subnets
O 7.7.7.7 [110/2] via 47.0.0.7, 00:38:07, FastEthernet2/0
8.0.0.0/32 is subnetted, 1 subnets
O 8.8.8.8 [110/65] via 48.0.0.8, 00:38:07, Serial1/0
12.0.0.0/24 is subnetted, 1 subnets
O E2 12.0.0.0 [110/20] via 47.0.0.7, 00:12:57, FastEthernet2/0
47.0.0.0/24 is subnetted, 1 subnets
C 47.0.0.0 is directly connected, FastEthernet2/0
45.0.0.0/24 is subnetted, 1 subnets
C 45.0.0.0 is directly connected, Serial1/1
R4#sh ip bgp
BGP table version is 19, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 47.0.0.7 3 32768 ?
r>i2.2.2.0/24 1.1.1.1 0 100 0 2 i
*> 4.4.4.0/24 0.0.0.0 0 32768 i
*> 5.5.5.0/24 45.0.0.5 0 0 5 i
*> 6.6.6.0/24 45.0.0.5 0 0 5 i
*> 7.7.7.7/32 47.0.0.7 2 32768 ?
*> 8.8.8.8/32 48.0.0.8 65 32768 ?
r>i12.0.0.0/24 1.1.1.1 0 100 0 2 ?
*> 17.0.0.0/24 47.0.0.7 2 32768 ?
*> 18.0.0.0/24 47.0.0.7 66 32768 ?
r> 45.0.0.0/24 45.0.0.5 0 0 5 ?
*> 47.0.0.0/24 0.0.0.0 0 32768 ?
*> 48.0.0.0/24 0.0.0.0 0 32768 ?
------------------------------------------------------------------------------------------------------------------------
R5#sh run
interface Loopback0
ip address 5.5.5.5 255.255.255.0
!
interface Loopback1
ip address 6.6.6.6 255.255.255.0
!
interface Serial1/0
ip address 45.0.0.5 255.255.255.0
serial restart-delay 0
!
router bgp 5
no synchronization
bgp log-neighbor-changes
network 5.5.5.0 mask 255.255.255.0
network 6.6.6.0 mask 255.255.255.0
redistribute connected
neighbor 45.0.0.4 remote-as 1
no auto-summary
!
line con 0
logging synchronous
stopbits 1
!
end
R5#sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
17.0.0.0/24 is subnetted, 1 subnets
B 17.0.0.0 [20/2] via 45.0.0.4, 00:35:25
1.0.0.0/32 is subnetted, 1 subnets
B 1.1.1.1 [20/3] via 45.0.0.4, 00:35:25
2.0.0.0/24 is subnetted, 1 subnets
B 2.2.2.0 [20/0] via 45.0.0.4, 00:48:31
48.0.0.0/24 is subnetted, 1 subnets
B 48.0.0.0 [20/0] via 45.0.0.4, 00:35:25
18.0.0.0/24 is subnetted, 1 subnets
B 18.0.0.0 [20/66] via 45.0.0.4, 00:35:25
4.0.0.0/24 is subnetted, 1 subnets
B 4.4.4.0 [20/0] via 45.0.0.4, 00:36:14
5.0.0.0/24 is subnetted, 1 subnets
C 5.5.5.0 is directly connected, Loopback0
6.0.0.0/24 is subnetted, 1 subnets
C 6.6.6.0 is directly connected, Loopback1
7.0.0.0/32 is subnetted, 1 subnets
B 7.7.7.7 [20/2] via 45.0.0.4, 00:35:27
8.0.0.0/32 is subnetted, 1 subnets
B 8.8.8.8 [20/65] via 45.0.0.4, 00:35:28
12.0.0.0/24 is subnetted, 1 subnets
B 12.0.0.0 [20/0] via 45.0.0.4, 00:33:17
47.0.0.0/24 is subnetted, 1 subnets
B 47.0.0.0 [20/0] via 45.0.0.4, 00:35:28
45.0.0.0/24 is subnetted, 1 subnets
C 45.0.0.0 is directly connected, Serial1/0
R5#sh ip bgp
BGP table version is 14, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 45.0.0.4 3 0 1 ?
*> 2.2.2.0/24 45.0.0.4 0 1 2 i
*> 4.4.4.0/24 45.0.0.4 0 0 1 i
*> 5.5.5.0/24 0.0.0.0 0 32768 i
*> 6.6.6.0/24 0.0.0.0 0 32768 i
*> 7.7.7.7/32 45.0.0.4 2 0 1 ?
*> 8.8.8.8/32 45.0.0.4 65 0 1 ?
*> 12.0.0.0/24 45.0.0.4 0 1 2 ?
*> 17.0.0.0/24 45.0.0.4 2 0 1 ?
*> 18.0.0.0/24 45.0.0.4 66 0 1 ?
*> 45.0.0.0/24 0.0.0.0 0 32768 ?
*> 47.0.0.0/24 45.0.0.4 0 0 1 ?
*> 48.0.0.0/24 45.0.0.4 0 0 1 ?
------------------------------------------------------------------------------------------------------------------------
R7#sh run
interface Loopback0
ip address 7.7.7.7 255.255.255.0
!
interface FastEthernet1/0
ip address 17.0.0.7 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 47.0.0.7 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 7.7.7.0 0.0.0.255 area 0
network 17.0.0.0 0.0.0.255 area 0
network 47.0.0.0 0.0.0.255 area 0
!
end
R7#sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
17.0.0.0/24 is subnetted, 1 subnets
C 17.0.0.0 is directly connected, FastEthernet1/0
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 17.0.0.1, 00:40:05, FastEthernet1/0
2.0.0.0/24 is subnetted, 1 subnets
O E2 2.2.2.0 [110/1] via 17.0.0.1, 00:40:05, FastEthernet1/0
48.0.0.0/24 is subnetted, 1 subnets
O 48.0.0.0 [110/65] via 47.0.0.4, 00:40:05, FastEthernet1/1
18.0.0.0/24 is subnetted, 1 subnets
O 18.0.0.0 [110/65] via 17.0.0.1, 00:40:05, FastEthernet1/0
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/2] via 47.0.0.4, 00:40:05, FastEthernet1/1
5.0.0.0/24 is subnetted, 1 subnets
O E2 5.5.5.0 [110/1] via 47.0.0.4, 00:40:06, FastEthernet1/1
6.0.0.0/24 is subnetted, 1 subnets
O E2 6.6.6.0 [110/1] via 47.0.0.4, 00:40:06, FastEthernet1/1
7.0.0.0/24 is subnetted, 1 subnets
C 7.7.7.0 is directly connected, Loopback0
8.0.0.0/32 is subnetted, 1 subnets
O 8.8.8.8 [110/66] via 47.0.0.4, 00:40:06, FastEthernet1/1
[110/66] via 17.0.0.1, 00:40:06, FastEthernet1/0
12.0.0.0/24 is subnetted, 1 subnets
O E2 12.0.0.0 [110/20] via 17.0.0.1, 00:14:58, FastEthernet1/0
47.0.0.0/24 is subnetted, 1 subnets
C 47.0.0.0 is directly connected, FastEthernet1/1
45.0.0.0/24 is subnetted, 1 subnets
O E2 45.0.0.0 [110/20] via 47.0.0.4, 00:11:58, FastEthernet1/1
R7#sh ip bgp
% BGP not active
------------------------------------------------------------------------------------------------------------------------
R8#sh run
interface Loopback0
ip address 8.8.8.8 255.255.255.0
!
interface Serial1/0
ip address 48.0.0.8 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 18.0.0.8 255.255.255.0
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 8.8.8.0 0.0.0.255 area 0
network 18.0.0.0 0.0.0.255 area 0
network 48.0.0.0 0.0.0.255 area 0
!
end
R8#sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
17.0.0.0/24 is subnetted, 1 subnets
O 17.0.0.0 [110/65] via 18.0.0.1, 00:40:52, Serial1/1
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 18.0.0.1, 00:40:52, Serial1/1
2.0.0.0/24 is subnetted, 1 subnets
O E2 2.2.2.0 [110/1] via 18.0.0.1, 00:40:52, Serial1/1
48.0.0.0/24 is subnetted, 1 subnets
C 48.0.0.0 is directly connected, Serial1/0
18.0.0.0/24 is subnetted, 1 subnets
C 18.0.0.0 is directly connected, Serial1/1
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/65] via 48.0.0.4, 00:40:52, Serial1/0
5.0.0.0/24 is subnetted, 1 subnets
O E2 5.5.5.0 [110/1] via 48.0.0.4, 00:40:52, Serial1/0
6.0.0.0/24 is subnetted, 1 subnets
O E2 6.6.6.0 [110/1] via 48.0.0.4, 00:40:52, Serial1/0
7.0.0.0/32 is subnetted, 1 subnets
O 7.7.7.7 [110/66] via 48.0.0.4, 00:40:53, Serial1/0
[110/66] via 18.0.0.1, 00:40:53, Serial1/1
8.0.0.0/24 is subnetted, 1 subnets
C 8.8.8.0 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
O E2 12.0.0.0 [110/20] via 18.0.0.1, 00:15:42, Serial1/1
47.0.0.0/24 is subnetted, 1 subnets
O 47.0.0.0 [110/65] via 48.0.0.4, 00:40:53, Serial1/0
45.0.0.0/24 is subnetted, 1 subnets
O E2 45.0.0.0 [110/20] via 48.0.0.4, 00:12:41, Serial1/0
R8#sh ip bgp
% BGP not active