在对交换机进行Vlan配置管理之前我们先来了解一下Vlan。Vlan(Virtual Local Area Network),英文直译虚拟本地区域网络,中文简称虚拟局域网,在局域网建设过程中用到的比较频繁的一项技术。Vlan工作在OSI七层参考模型的第二层和第三层,每个Vlan都是一个广播域,所以在一个局域网中划分Vlan相当于是增加了广播域,减少了冲突域,Vlan间要想进行通讯需要借助具备路由功能的三层设备(三层核心交换机或者是路由器)。

Vlan可以基于端口、协议、mac地址、组播、ip子网划分,在工作中使用频繁的是基于端口划分Vlan,此文的演示用例也会基于端口对Vlan进行配置管理。

由于不同厂商的操作命令存在差异,在此篇文章中会基于华为厂商的设备进行Vlan的配置和管理,希望能对您的工作有所帮助。

1、华为交换机Vlan配置管理

在正式对华为交换机配置之前我们先来了解一下华为交换机的三种视图模式:用户视图、系统视图、接口视图。用户视图模式下用来查看交换机运行状态和统计信息,系统视图下用来进行系统参数配置,接口视图下用来进行接口配置。

1.1、登录到交换机(查看vlan)

首先出现的<xiaozc>模式是用户模式,在此模式下我们可以通过dis vlan summary查看交换机上配置了多少vlan ,如下图:

零基础学习网络之Vlan配置与管理实操_实操

在用户模式下通过dis vlan vlanid查看vlan的详细信息,如下图:

零基础学习网络之Vlan配置与管理实操_vlan_02

另外通过dis current-configuration可以查看交换机的整体配置,里面也包含vlan的配置信息。

1.2、进入配置模式(配置vlan)

在用户模式下输入system-view命令即可进入配置模式,在配置模式下输入quit即可退到用户模式,如图:

零基础学习网络之Vlan配置与管理实操_实操_03

在配置模式进行vlan的创建,例如需要创建vlan608,为vlan608添加描述为xl,如图:

[xiaozc]vlan 608

Info: This operation may take a few seconds. Please wait for a moment....done.

[xiaozc-vlan608]description xl

零基础学习网络之Vlan配置与管理实操_华为交换机_04

1.3、进入接口模式

为vlan配置地址,例如需要为vlan 608 配置192.168.77.254/24的地址,需要进入vlan接口模式,在配置模式下输入interface vlan 608进入vlan接口模式,如图:

[xiaozc]interface vlan 608

[xiaozc-Vlanif608]dis this    --在vlan接口模式下查看vlan自身的配置

interface Vlanif608

return

[xiaozc-Vlanif608]ip add 192.168.77.254 24   --设置vlan子接口的地址

[xiaozc-Vlanif608]dis this

interface Vlanif608

ip address 192.168.77.254 255.255.255.0

return

零基础学习网络之Vlan配置与管理实操_vlan_05

1.4、将接口加入到新创建的vlan

将接口加入到vlan需要进入到接口模式,在配置模式下或者接口模式下输入interface 接口id就可以进入到接口配置模式,例如要将GigabitEthernet1/10/0/27加入到vlan 608,配置如下:

[xiaozc-Vlanif608]inter GigabitEthernet1/10/0/27

[xiaozc-GigabitEthernet1/10/0/27]port link-type access

Info: This operation may take a few seconds. Please wait for a moment...done.

[xiaozc-GigabitEthernet1/10/0/27]port default vlan 608

零基础学习网络之Vlan配置与管理实操_华为交换机_06

将多个端口同时加入到vlan 608,配置如下:

[xiaozc]interface range gigabitEthernet1/10/0/7 to GigabitEthernet 1/10/0/11 --同时进入多个接口

[xiaozc-port-group]port link-type access   --将接口改为access模式

[xiaozc-port-group]port default vlan 608   --将接口的默认vlan改成vlan 608

1.5、删除vlan

当vlan接口有ip地址的时候需要先将vlan接口地址进行删除,配置如下:

[xiaozc]inter vlan 608

[xiaozc-Vlanif608]undo ip add   --取消vlan子接口的地址

删除完成vlan接口地址后可以对vlan进行删除,配置如下:

[xiaozc]undo vlan 608     --删除vlan

Info: This operation may take a few seconds. Please wait for a moment....done.

[xiaozc]dis vlan 608                 

Error: The VLAN does not exist.  --证明vlan删除成功

至此,简单对华为交换机vlan的配置管理完成。