Shortest Path

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6682    Accepted Submission(s): 1636

Problem Description

When YY was a boy and LMY was a girl, they trained for NOI (National Olympiad in Informatics) in GD team. One day, GD team’s coach, Prof. GUO asked them to solve the following shortest-path problem.
There is a weighted directed multigraph G. And there are following two operations for the weighted directed multigraph:
(1) Mark a vertex in the graph.
(2) Find the shortest-path between two vertices only through marked vertices.
For it was the first time that LMY faced such a problem, she was very nervous. At this moment, YY decided to help LMY to analyze the shortest-path problem. With the help of YY, LMY solved the problem at once, admiring YY very much. Since then, when LMY meets problems, she always calls YY to analyze the problems for her. Of course, YY is very glad to help LMY. Finally, it is known to us all, YY and LMY become programming lovers.
Could you also solve the shortest-path problem?

Input

The input consists of multiple test cases. For each test case, the first line contains three integers N, M and Q, where N is the number of vertices in the given graph, N≤300; M is the number of arcs, M≤100000; and Q is the number of operations, Q ≤100000. All vertices are number as 0, 1, 2, … , N - 1, respectively. Initially all vertices are unmarked. Each of the next M lines describes an arc by three integers (x, y, c): initial vertex (x), terminal vertex (y), and the weight of the arc (c). (c > 0) Then each of the next Q lines describes an operation, where operation “0 x” represents that vertex x is marked, and operation “1 x y” finds the length of shortest-path between x and y only through marked vertices. There is a blank line between two consecutive test cases.
End of input is indicated by a line containing N = M = Q = 0.

Output

Start each test case with "Case #:" on a single line, where # is the case number starting from 1.
For operation “0 x”, if vertex x has been marked, output “ERROR! At point x”.
For operation “1 x y”, if vertex x or vertex y isn’t marked, output “ERROR! At path x to y”; if y isn’t reachable from x through marked vertices, output “No such path”; otherwise output the length of the shortest-path. The format is showed as sample output.
There is a blank line between two consecutive test cases.

Sample Input


5 10 10 1 2 6335 0 4 5725 3 3 6963 4 0 8146 1 2 9962 1 0 1943 2 1 2392 4 2 154 2 2 7422 1 3 9896 0 1 0 3 0 2 0 4 0 4 0 1 1 3 3 1 1 1 0 3 0 4 0 0 0


Sample Output


Case 1: ERROR! At point 4 ERROR! At point 1 0 0 ERROR! At point 3 ERROR! At point 4


题意:这里我只说关键点,这里的路是单向的,其中一问从 x 到 y 的最短路(x,y和经过的点都必须被标记过),如果x,或y没有被标记过输出“ERROR! At path x to y”。

题解:floyd算法需要变形一下,作用为以k为桥梁i到j的最短路距离,然后每标记一个点,用一次算法,使得所有的最短路都是通过标记的点得到的。

具体代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<map>
#define N 310
using namespace std;
const int INF=999999999;
int m,n,k;
int d[N][N];
map<int,int> mp;
int minn(int a,int b)
{
return a<b?a:b;
}
void floyd(int k)//以k为桥梁
{
int i,j;
for(i=0;i<n;i++)
if(i!=k)
for(j=0;j<n;j++)
if(i!=j&&k!=j)
d[i][j]=minn(d[i][j],d[i][k]+d[k][j]);
}
int main()
{
int t=0;
while(cin>>n>>m>>k,n+m+k)
{
t++;
mp.clear();
int i,j;
for(i=0;i<N;i++)
for(j=0;j<N;j++)
d[i][j]=(i==j?0:INF);
for(i=0;i<m;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
if(d[a][b]>c)
d[a][b]=c;//路是单向的,这里WA了好几次!!!
}
if(t==1)
printf("Case %d:\n",t);
else
printf("\nCase %d:\n",t);
while(k--)
{
int a;
scanf("%d",&a);
if(a)
{
int x,y;
scanf("%d%d",&x,&y);
if(mp.find(x)==mp.end()||mp.find(y)==mp.end())//x,y没被标记
printf("ERROR! At path %d to %d\n",x,y);
else if(d[x][y]==INF)//此路不通
printf("No such path\n");
else
printf("%d\n",d[x][y]);
}
else
{
int b;
scanf("%d",&b);
if(mp.find(b)==mp.end())//没找到,标记该点
mp[b]=1,floyd(b);
else
printf("ERROR! At point %d\n",b);
}
}
}
return 0;
}