Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

题目翻译:给出一个数字n,给出一个集合{1,2,4,8,16,32,64。。。。},求n有多少种不同的由集合内的数字的加和情况。

解题思路:本以为是母函数,但是在网上搜了一下结果发现是递推,可以有前面推出后面的结果,原因是和2的指数关系有关。

 

#include<cstdio>
int dp[1000000+5]={0,1,2,2},i,n;
int main(){
while(scanf("%d",&n)==1){
for(i=4;i<=n+1;i+=2){
dp[i-1]=dp[i-2];
dp[i]=(dp[i-1]+dp[i>>1])%1000000000;
}
printf("%d\n",dp[n]);
}
return 0;
}