IPA-taskpacket001BGP的基本原理实验一:BGP路由传递原则


实验目标:掌握BGP的路由传递原则

实验TOP



BGP的基本原理_interface

BGP的基本原理_router_02



基本配置


R1


!

hostname R1

!

no ip domain lookup

!

interface Loopback0

ipaddress 1.1.1.1 255.255.255.0

!

interface Loopback10

ipaddress 10.10.10.10 255.255.255.0

ipospf network point-to-point

!

interface Serial1/0

ipaddress 12.1.1.1 255.255.255.0

!

interface Serial1/1

ipaddress 13.1.1.1 255.255.255.0

!

router ospf 10

router-id 1.1.1.1

network 10.10.10.0 0.0.0.255 area 0

network 12.1.1.0 0.0.0.255 area 0

network 13.1.1.0 0.0.0.255 area 0

!

router bgp 65001

nosynchronization

bgprouter-id 1.1.1.1

network 1.1.1.0 mask 255.255.255.0

neighbor 12.1.1.2 remote-as 65001

neighbor 13.1.1.3 remote-as 65001

noauto-summary

!



R2


!

hostname R2

!

no ip domain lookup

!

interface Loopback0

ipaddress 2.2.2.2 255.255.255.0

!

interface Loopback10

ipaddress 20.20.20.20 255.255.255.0

ipospf network point-to-point

!

interface Serial1/0

ipaddress 24.2.2.2 255.255.255.0

!

interface Serial1/1

ipaddress 12.1.1.2 255.255.255.0

!        

router ospf 10

router-id 2.2.2.2

network 12.1.1.0 0.0.0.255 area 0

network 20.20.20.0 0.0.0.255 area 0

network 24.2.2.0 0.0.0.255 area 0

!

router bgp 65001

nosynchronization

bgprouter-id 2.2.2.2

network 2.2.2.0 mask 255.255.255.0

neighbor12.1.1.1 remote-as 65001

neighbor 24.2.2.4 remote-as 65001

noauto-summary

!



R3


!

hostname R3

!

no ip domain lookup

!

interface Loopback0

ipaddress 3.3.3.3 255.255.255.0

!

interface Loopback10

ipaddress 30.30.30.30 255.255.255.0

ipospf network point-to-point

!

interface Serial1/1

ipaddress 13.1.1.3 255.255.255.0

!

interface Serial1/0

ipaddress 34.3.3.3 255.255.255.0

!        

router ospf 10

router-id 3.3.3.3

network 13.1.1.0 0.0.0.255 area 0

network 30.30.30.0 0.0.0.255 area 0

network34.3.3.0 0.0.0.255 area 0

!

router bgp 65001

nosynchronization

bgprouter-id 3.3.3.3

network 3.3.3.0 mask 255.255.255.0

neighbor 13.1.1.1 remote-as 65001

neighbor 34.3.3.4 remote-as 65001

no auto-summary

!



R4


!

hostname R4

!

no ip domain lookup

!

interface Loopback0

ipaddress 4.4.4.4 255.255.255.0

!

interface Loopback10

ipaddress 40.40.40.40 255.255.255.0

ipospf network point-to-point

!

interface Serial1/0

ipaddress 24.2.2.4 255.255.255.0

!

interface Serial1/1

ipaddress 34.3.3.4 255.255.255.0

!

Interface Serial1/2

Ip address 45.4.4.4 255.255.255.0

!

Interface Serial1/3

Ip address 46.4.4.4 255.255.255.0

!

router ospf 10

router-id 4.4.4.4

network 40.40.40.0 0.0.0.255 area 0

network 24.2.2.0 0.0.0.255 area 0

network 34.3.3.0 0.0.0.255 area 0

!

router bgp 65001

nosynchronization

bgprouter-id 4.4.4.4

network 4.4.4.0 mask 255.255.255.0

neighbor 24.2.2.2 remote-as 65001

neighbor 34.3.3.3 remote-as 65001

neighbor 45.4.4.5 remote-as 65002

neighbor 46.4.4.6 remote-as 65003

noauto-summary

!



R5


!

Hostname R5

!

no ip domain lookup

!

interface Loopback0

ipaddress 5.5.5.5 255.255.255.0

!

interface Serial1/0

ipaddress 45.4.4.5 255.255.255.0

!

router bgp 65002

nosynchronization

bgprouter-id 5.5.5.5

network 5.5.5.0 mask 255.255.255.0

neighbor 45.4.4.4 remote-as 65001

noauto-summary

!



R6


!

hostnameR6

!

interfaceLoopback0

ip address 6.6.6.6 255.255.255.0

!

interfaceSerial1/0

ip address 46.4.4.6 255.255.255.0

!

routerbgp 65003

no synchronization

bgp router-id 6.6.6.6

network 6.6.6.0 mask 255.255.255.0

neighbor 46.4.4.4 remote-as 65001

no auto-summary

!


批注:路由器接口默认是关闭的,所以应将对应的接口开启




基本配置完成之后,我们开始检查BGP对等体关系是否正常建立


R1#show ip bgp summary

BGP router identifier 1.1.1.1, local AS number 65001

BGP table version is 4, main routing table version 4

3 network entries using 303 bytes of memory

3 path entries using 144 bytes of memory

2 BGP path attribute entries using 120 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 567 total bytes of memory

BGP activity 3/0 prefixes, 3/0 paths, scan interval 60 secs


Neighbor        V    AS MsgRcvd MsgSent   TblVer InQ OutQ Up/Down  State/PfxRcd

12.1.1.2        4 65001      10     10        4    0   0 00:05:28        1

13.1.1.3        4 65001       9      9        4    0   0 00:04:42        1

R1#


//R1此时已经正常与R2R3建立iBGP对等体关系



R2#show ip bgp summary

BGP router identifier 2.2.2.2, local AS number 65001

BGP table version is 4, main routing table version 4

5 network entries using 505 bytes of memory

5 path entries using 240 bytes of memory

4 BGP path attribute entries using 240 bytes of memory

2 BGP AS-PATH entries using 48 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1033 total bytes of memory

BGP activity 5/0 prefixes, 5/0 paths, scan interval 60 secs


Neighbor        V    AS MsgRcvd MsgSent   TblVer InQ OutQ Up/Down  State/PfxRcd

12.1.1.1        4 65001      11     11        4   0    0 00:06:13        1

24.2.2.4        4 65001      11      9        4    0   0 00:04:51        3

R2#


//R2此时已经正常与R1R4建立iBGP对等体关系



R3#show ip bgp summary

BGP router identifier 3.3.3.3, local AS number 65001

BGP table version is 4, main routing table version 4

5 network entries using 505 bytes of memory

5 path entries using 240 bytes of memory

4 BGP path attribute entries using 240 bytes of memory

2 BGP AS-PATH entries using 48 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1033 total bytes of memory

BGP activity 5/0 prefixes, 5/0 paths, scan interval 60 secs


Neighbor        V    AS MsgRcvd MsgSent   TblVer InQ OutQ Up/Down  State/PfxRcd

13.1.1.1        4 65001      10     10        4    0   0 00:05:53        1

34.3.3.4        4 65001      12     10        4    0   0 00:05:16        3

R3#


//R3此时已经正常与R1R4建立iBGP对等体关系



R4#show ip bgp summary

BGP router identifier 4.4.4.4, local AS number 65001

BGP table version is 6, main routing table version 6

5 network entries using 505 bytes of memory

5 path entries using 240 bytes of memory

4 BGP path attribute entries using 240 bytes of memory

2 BGP AS-PATH entries using 48 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1033 total bytes of memory

BGP activity 5/0 prefixes, 5/0 paths, scan interval 60 secs


Neighbor        V    AS MsgRcvd MsgSent   TblVer InQ OutQ Up/Down  State/PfxRcd

24.2.2.2        4 65001      11     13        6    0   0 00:06:13        1

34.3.3.3        4 65001      11     13        6    0   0 00:06:13        1

45.4.4.5        4 65002       9     11        6    0   0 00:04:34        1

46.4.4.6        4 65003       9     11        6    0   0 00:04:10        1

R4#


//R4此时已经正常与R2R3建立iBGP对等体关系,并且与R5R6建立eBGP对等体关系



R5#show ip bgp summary

BGP router identifier 5.5.5.5, local AS number 65002

BGP table version is 6, main routing table version 6

5 network entries using 505 bytes of memory

5 path entries using 240 bytes of memory

4 BGP path attribute entries using 240 bytes of memory

2 BGP AS-PATH entries using 48 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1033 total bytes of memory

BGP activity 5/0 prefixes, 5/0 paths, scan interval 60 secs


Neighbor        V    AS MsgRcvd MsgSent   TblVer InQ OutQ Up/Down  State/PfxRcd

45.4.4.4        4 65001      11      9        6    0   0 00:04:53        4

R5#


//R5此时已经正常与R4建立eBGP对等体关系



R6#show ip bgp summary

BGP router identifier 6.6.6.6, local AS number 65003

BGP table version is 6, main routing table version 6

5 network entries using 505 bytes of memory

5 path entries using 240 bytes of memory

4 BGP path attribute entries using 240 bytes of memory

2 BGP AS-PATH entries using 48 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1033 total bytes of memory

BGP activity 5/0 prefixes, 5/0 paths, scan interval 60 secs


Neighbor        V    AS MsgRcvd MsgSent   TblVer InQ OutQ Up/Down  State/PfxRcd

46.4.4.4        4 65001      11      9        6    0   0 00:04:56        4

R6#


//R6此时已经正常与R4建立eBGP对等体关系



调试:

1.IBGP路由器从直连IBGP对等体学来的路由条目不会再传送给另外一个直连IBGP对等体。


如下图所示,如果R3不会将自己从iBGP对等体R1学习到的1.1.1.0/24网段传递给另一个iBGP对等体R4证明此结论正确。


BGP的基本原理_network_03


首先我们查看R3bgp表:


R3#show ip bgp

BGP table version is 4, local router ID is3.3.3.3

Status codes: s suppressed, d damped, hhistory, * valid, > best, i - internal,

             r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? -incomplete


 Network          Next Hop            Metric LocPrf Weight Path

*>i1.1.1.0/24      13.1.1.1                 0    100      0 i

*> 3.3.3.0/24       0.0.0.0                  0         32768 i

*>i4.4.4.0/24       34.3.3.4                 0    100     0 i

* i5.5.5.0/24       45.4.4.5                 0    100     0 65002 i

* i6.6.6.0/24       46.4.4.6                 0    100     0 65003 i


//我们发现R3学习到了R1lo0


再来查看R4的BGP表

R4#show ip bgp

BGP table version is 6, local router ID is 4.4.4.4

Status codes: s suppressed, d damped, h history, * valid, > best, i -internal,

             r RIB-failure, SStale

Origin codes: i - IGP, e - EGP, ? - incomplete


  Network          Next Hop            Metric LocPrf Weight Path

*>i2.2.2.0/24      24.2.2.2                 0    100     0 i

*>i3.3.3.0/24      34.3.3.3                 0    100     0 i

*> 4.4.4.0/24       0.0.0.0                  0        32768 i

*> 5.5.5.0/24      45.4.4.5                 0             0 65002 i

*> 6.6.6.0/24      46.4.4.6                 0             0 65003 i

R4#


//我们发现R4并没有学习到了R1lo0



2.IBGP路由器会将自己从其他IBGP对等体学来的条目传给自身直连的EBGP对等体。


如果R5学习到R3的3.3.3.0/24路由条目,确定此结论正确。


首先我们查看R4BGP


R4#show ip bgp

BGP table version is 6, local router ID is4.4.4.4

Status codes: s suppressed, d damped, hhistory, * valid, > best, i - internal,

            r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? -incomplete


 Network          Next Hop            Metric LocPrf Weight Path

*>i2.2.2.0/24       24.2.2.2                 0    100     0 i

*>i3.3.3.0/24       34.3.3.3                 0    100     0 i

*> 4.4.4.0/24       0.0.0.0                  0         32768 i

*> 5.5.5.0/24       45.4.4.5                 0             0 65002 i

*> 6.6.6.0/24       46.4.4.6                 0             0 65003 i

R4#


//R4学习到R3的路由


再来查看R5BGP

R5#show ip bgp

BGP table version is 6, local router ID is5.5.5.5

Status codes: s suppressed, d damped, hhistory, * valid, > best, i - internal,

            r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? -incomplete


 Network          Next Hop            Metric LocPrf Weight Path

*> 2.2.2.0/24       45.4.4.4                               0 65001 i

*>3.3.3.0/24       45.4.4.4                               0 65001 i

*> 4.4.4.0/24       45.4.4.4                 0             0 65001 i

*> 5.5.5.0/24       0.0.0.0                  0         32768 i

*> 6.6.6.0/24       45.4.4.4                               0 65001 65003 i

R5#


//我们发现R5确实学习到了R3 的路由,证明上结论没有问题



3.从EBGP对等体学来的路由条目会传递给自身直连的IBGP对等体。


如果R4eBGP对等体R5学习到5.5.5.0/24网段可以传递给iBGP对等体R3,则可证明结论正确

那么首先我们查看R4BGP


R4#show ip bgp

BGP table version is 6, local router ID is4.4.4.4

Status codes: s suppressed, d damped, hhistory, * valid, > best, i - internal,

            r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? -incomplete


 Network          Next Hop            Metric LocPrf Weight Path

*>i2.2.2.0/24       24.2.2.2                 0    100     0 i

*>i3.3.3.0/24       34.3.3.3                 0    100     0 i

*> 4.4.4.0/24       0.0.0.0                  0         32768 i

*>5.5.5.0/24       45.4.4.5                 0             0 65002 i

*> 6.6.6.0/24       46.4.4.6                 0             0 65003 i

R4#


//我们发现R4学习到了5.5.5.0的路由


再来查看R3bgp


R3#show ip bgp

BGP table version is 4, local router ID is3.3.3.3

Status codes: s suppressed, d damped, hhistory, * valid, > best, i - internal,

            r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete


 Network          Next Hop            Metric LocPrf Weight Path

*>i1.1.1.0/24       13.1.1.1                 0    100     0 i

*> 3.3.3.0/24       0.0.0.0                  0         32768 i

*>i4.4.4.0/24       34.3.3.4                 0    100     0 i

*i5.5.5.0/24       45.4.4.5                 0    100     0 65002 i

* i6.6.6.0/24       46.4.4.6                 0    100     0 65003 i

R3#


//我们发现R3也学习到了5.5.5.0/24,说明R4会传递R55.5.5.0/24网段



4.从EBGP对等体学来的路由条目会传递给其他EBGP对等体。


我们可以在R5和R6上测试,观察R4从eBGP对等体R6学习到的6.6.6.0/24是否会传递给eBGP对等体R5


首先,我们查看R4的bgp表


R4#show ip bgp

BGP table version is 6, local router ID is 4.4.4.4

Status codes: s suppressed, d damped, h history, * valid, >best, i - internal,

             rRIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete


  Network          Next Hop            Metric LocPrf Weight Path

*>i2.2.2.0/24      24.2.2.2                 0    100     0 i

*>i3.3.3.0/24      34.3.3.3                 0    100     0 i

*> 4.4.4.0/24      0.0.0.0                  0         32768 i

*> 5.5.5.0/24      45.4.4.5                 0             0 65002 i

*> 6.6.6.0/24       46.4.4.6                 0             0 65003 i

R4#


//我们发现R4学习到了R6的6.6.6.0/24


再来查看R5的bgp表



R5#showip bgp

BGPtable version is 6, local router ID is 5.5.5.5

Statuscodes: s suppressed, d damped, h history, * valid, > best, i - internal,

             r RIB-failure, S Stale

Origincodes: i - IGP, e - EGP, ? - incomplete


  Network          Next Hop            Metric LocPrf Weight Path

*>2.2.2.0/24       45.4.4.4                               0 65001 i

*>3.3.3.0/24       45.4.4.4                               0 65001 i

*>4.4.4.0/24       45.4.4.4                 0             0 65001 i

*>5.5.5.0/24       0.0.0.0                  0         32768 i

*> 6.6.6.0/24       45.4.4.4                               0 65001 65003 i


//此时R5也同样学习到R66.6.6.0/24网络,证明结论没有问题



5.从IBGP对等体学来的路由条目再传送给EBGP对等体,下一跳会改成自己的出口。


我们测试R22.2.2.0/24网段在传递给iBGP对等体R4后,由R4在传递给直连的eBGP对等体,下一跳是否修改?


首先,我们查看R4BGP


R4#showip bgp

BGPtable version is 6, local router ID is 4.4.4.4

Statuscodes: s suppressed, d damped, h history, * valid, > best, i - internal,

             r RIB-failure, S Stale

Origincodes: i - IGP, e - EGP, ? - incomplete


  Network          Next Hop            Metric LocPrf Weight Path

*>i2.2.2.0/24       24.2.2.2                0    100      0 i

*>i3.3.3.0/24       34.3.3.3                 0    100     0 i

*>4.4.4.0/24       0.0.0.0                  0         32768 i

*>5.5.5.0/24       45.4.4.5                 0             0 65002 i

*>6.6.6.0/24       46.4.4.6                 0             0 65003 i


//我们发现此时R4iBGP对等体R2学习到的2.2.2.0/24网段的下一跳为R2的出口IP地址24.2.2.2


再来查看R5BGP


R5#showip bgp

BGPtable version is 6, local router ID is 5.5.5.5

Statuscodes: s suppressed, d damped, h history, * valid, > best, i - internal,

             r RIB-failure, S Stale

Origincodes: i - IGP, e - EGP, ? - incomplete


  Network          Next Hop            Metric LocPrf Weight Path

*> 2.2.2.0/24       45.4.4.4                               0 65001 i

*>3.3.3.0/24       45.4.4.4                               0 65001 i

*>4.4.4.0/24       45.4.4.4                 0             0 65001 i

*>5.5.5.0/24       0.0.0.0                  0         32768 i

*>6.6.6.0/24       45.4.4.4                               0 65001 65003 i

R5#


//我们发现R5学习到的2.2.2.0/24的下一跳已经更改为R4 的出口45.4.4.4



6.从EBGP对等体学来的路由条目再传送给IBGP对等体,下一跳不会更改为自己的出口。


这里测试R4从eBGP对等体R5学习到的5.5.5.0/24在传递给iBGP对等体R2,下一跳是否更改


首先,我们查看R4的BGP表

R4#show ip bgp

BGP table version is 6, localrouter ID is 4.4.4.4

Status codes: s suppressed, ddamped, h history, * valid, > best, i - internal,

             r RIB-failure, S Stale

Origin codes: i - IGP, e -EGP, ? - incomplete


  Network          Next Hop            Metric LocPrf Weight Path

*>i2.2.2.0/24       24.2.2.2                 0    100     0 i

*>i3.3.3.0/24       34.3.3.3                 0    100     0 i

*> 4.4.4.0/24       0.0.0.0                  0         32768 i

*> 5.5.5.0/24       45.4.4.5                 0             0 65002 i

*> 6.6.6.0/24       46.4.4.6                 0             0 65003 i

R4#


//我们发现R4学习到的5.5.5.0/24网段的下一跳IP地址是45.4.4.5


我们再来查看R2的BGP表


R2#show ip bgp

BGP table version is 4, localrouter ID is 2.2.2.2

Status codes: s suppressed, ddamped, h history, * valid, > best, i - internal,

             r RIB-failure, S Stale

Origin codes: i - IGP, e -EGP, ? - incomplete


  Network          Next Hop            Metric LocPrf Weight Path

*>i1.1.1.0/24       12.1.1.1                 0    100     0 i

*> 2.2.2.0/24       0.0.0.0                  0         32768 i

*>i4.4.4.0/24       24.2.2.4                 0    100     0 i

* i5.5.5.0/24       45.4.4.5                 0    100     0 65002 i

* i6.6.6.0/24       46.4.4.6                 0    100     0 65003 i

R2#


//我们得出R2学习到的5.5.5.0/24网段,下一跳IP地址依然是为45.4.4.5,没有改变。

并且在R2的BGP中没有出现大于号(即最后路径的标记),那么R2是不会将它装入路由表的,我们查看R2的路由表

R2#show ip route bgp

    1.0.0.0/24 is subnetted, 1 subnets

B       1.1.1.0 [200/0] via 12.1.1.1, 00:20:10

    4.0.0.0/24 is subnetted, 1 subnets

B       4.4.4.0 [200/0] via 24.2.2.4, 00:18:18

R2#


//我们发现R2并没有将5.5.5.0/24网段装入路由表,原因是由于在R2的BGP中对应的下一跳地址45.4.4.5所在的网段45.4.4.0/24网段,对于R2 而言不可达造成。我们再来查看R2的IGP路由表:

R2#show ip route

Codes: C - connected, S -static, R - RIP, M - mobile, B - BGP

      D - EIGRP, EX - EIGRP external, O -OSPF, IA - OSPF inter area

      N1 - OSPF NSSA external type 1, N2 -OSPF NSSA external type 2

      E1 - OSPF external type 1, E2 - OSPFexternal type 2

      i - IS-IS, su - IS-IS summary, L1 -IS-IS level-1, L2 - IS-IS level-2

      ia - IS-IS inter area, * - candidatedefault, U - per-user static route

      o - ODR, P - periodic downloaded staticroute


Gateway of last resort is notset


    34.0.0.0/24 is subnetted, 1 subnets

O       34.3.3.0 [110/128] via 24.2.2.4, 00:19:55,Serial1/0

    1.0.0.0/24 is subnetted, 1 subnets

B       1.1.1.0 [200/0] via 12.1.1.1, 00:20:02

    2.0.0.0/24 is subnetted, 1 subnets

C       2.2.2.0 is directly connected, Loopback0

    4.0.0.0/24 is subnetted, 1 subnets

B       4.4.4.0 [200/0] via 24.2.2.4, 00:18:10

    20.0.0.0/24 is subnetted, 1 subnets

C       20.20.20.0 is directly connected,Loopback10

    24.0.0.0/24 is subnetted, 1 subnets

C       24.2.2.0 is directly connected,Serial1/0

    40.0.0.0/24 is subnetted, 1 subnets

O       40.40.40.0 [110/65] via 24.2.2.4, 00:19:55,Serial1/0

    10.0.0.0/24 is subnetted, 1 subnets

O       10.10.10.0 [110/65] via 12.1.1.1,00:19:55, Serial1/1

    12.0.0.0/24 is subnetted, 1 subnets

C       12.1.1.0 is directly connected,Serial1/1

    13.0.0.0/24 is subnetted, 1 subnets

O       13.1.1.0 [110/128] via 12.1.1.1,00:19:55, Serial1/1

    30.0.0.0/24 is subnetted, 1 subnets

O       30.30.30.0 [110/129] via 12.1.1.1,00:19:55, Serial1/1

                  [110/129] via 24.2.2.4,00:19:55, Serial1/0

R2#


//我们发现R2确实没有对应的45.4.4.0/24网段的路由在IGP路由表中。


补充:如果想让R2将学习到的5.5.5.0/24,装入对应的路由表中,我们必须满足下一跳可达,这里可以用静态路由、重发布IGP、next-hop-self等完成可达。



7.从EBGP对等体学来的路由条目,再传送给EBGP路由器,下一跳更改为自己的出口。


这里我们测试R5从eBGP对等体R4学习到R6的6.6.6.0/24网段,下一跳是否会更改

首先,我们查看R4 的BGP表

R4#show ip bgp

BGP table version is 6, localrouter ID is 4.4.4.4

Status codes: s suppressed, ddamped, h history, * valid, > best, i - internal,

             r RIB-failure, S Stale

Origin codes: i - IGP, e -EGP, ? - incomplete


  Network          Next Hop            Metric LocPrf Weight Path

*>i2.2.2.0/24       24.2.2.2                 0    100     0 i

*>i3.3.3.0/24       34.3.3.3                 0    100     0 i

*> 4.4.4.0/24       0.0.0.0                  0         32768 i

*> 5.5.5.0/24       45.4.4.5                 0             0 65002 i

*> 6.6.6.0/24       46.4.4.6                0             0 65003 i

R4#


//我们得出R4学习到R6的6.6.6.0/24网段,下一跳为R6的出口IP地址46.4.4.6


然后我们查看R5的BGP表

R5#show ip bgp

BGP table version is 6, localrouter ID is 5.5.5.5

Status codes: s suppressed, ddamped, h history, * valid, > best, i - internal,

             r RIB-failure, S Stale

Origin codes: i - IGP, e -EGP, ? - incomplete


  Network          Next Hop            Metric LocPrf Weight Path

*> 2.2.2.0/24       45.4.4.4                               0 65001 i

*> 3.3.3.0/24       45.4.4.4                               0 65001 i

*> 4.4.4.0/24       45.4.4.4                 0             0 65001 i

*> 5.5.5.0/24       0.0.0.0                  0         32768 i

*> 6.6.6.0/24       45.4.4.4                              0 65001 65003 i

R5#


//我们发现R5学习到的6.6.6.0/24网段,下一跳变更为R4 的出口IP地址45.4.4.4


补充:此时我们发现整个网络没有收敛,这是由于BGP路由传递原则造成,这里可以采用Full-Mesh、RR等解决方案来完成收敛。