接口类型                    选举 DR/BDR      hello间隔           动态发现邻居             子网包含2台以上路由器
广播                            是                      10                           是                                  是
点到点                    不选举DR/BDR       10                            是                                   否
非广播(NBMA)             是                30                        neighbor指定邻居               是
点到多点              不选择DR/BDR         30                             是                                 是
点到多点非广播   不选择DR/BDR   30                           neighbor指定邻居                 是


点到点即为帧中继点到点子接口的默认配置(interface type numpoint to point )
NBMA即为帧中继物理接口和多点子接口的默认配置 (interface type nummultipoint )

网络类型非广播(NBMA)
R1#sh run int s0/0.1
Building configuration...

Current configuration : 175 bytes
!
interface Serial0/0.1 multipoint
ip address 10.2.123.1 255.255.255.248
frame-relay interface-dlci 102
frame-relay interface-dlci 103
frame-relay interface-dlci 104
end
R1#sh run | begin router ospf 1
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
neighbor 10.2.123.4
neighbor 10.2.123.3
neighbor 10.2.123.2
!
R2#sh run int s0/1.1
Building configuration...

Current configuration : 201 bytes
!
interface Serial0/1.1 multipoint
ip address 10.2.123.2 255.255.255.248
frame-relay map ip 10.2.123.3 101 broadcast
frame-relay map ip 10.2.123.4 101 broadcast
frame-relay interface-dlci 101
end
R2#sh run | begin router ospf 1
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
neighbor 10.2.123.1
!
网络类型点到多点
R1#sh run int s0/0.1
Building configuration...

Current configuration : 175 bytes
!
interface Serial0/0.1 multipoint
ip address 10.2.123.1 255.255.255.248
frame-relay interface-dlci 102
frame-relay interface-dlci 103
frame-relay interface-dlci 104
ip ospf network point-to-multipoint
end
R1#sh run | begin router ospf 1
router ospf 1
router-id 1.1.1.1
network 10.0.0.0 0.255.255.255 area 0
R2#sh run int s0/1.1
Building configuration...

Current configuration : 201 bytes
!
interface Serial0/1.1 multipoint
ip address 10.2.123.2 255.255.255.248
frame-relay map ip 10.2.123.3 101 broadcast
frame-relay map ip 10.2.123.4 101 broadcast
frame-relay interface-dlci 101
ip ospf network point-to-multipoint
end
R2#sh run | begin router ospf 1
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
网络类型点到多点非广播
与点到多点唯一不同的是在子接口模式下,
ip ospf network point-to-multipoint改成ip ospfnetwork point-to-multipoint non-broadcast