Hat’s Words
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9037 Accepted Submission(s): 3231
Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
Sample Input
a ahat hat hatword hziee word
Sample Output
ahat hatword
Author
戴帽子的
题目分析:
用字典树先把字符串存下,然后利用深搜trie,利用指针跳转判断当前串能否被严格分成两个已有的串
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <iostream>
using namespace std;
char s[50007][100];
struct Node
{
int cnt;
Node * b[27];
Node ( )
:cnt(0)
{
memset ( b , 0 , sizeof ( b ) );
}
}*root;
bool flag;
void dfs ( int i , Node * p , int state = 0, int j = 0 )
{
if ( flag ) return;
if ( !s[i][j] )
{
if ( state == 1 && p->cnt == 1 ) flag = true;
return;
}
int x = s[i][j]-'a';
if ( p->cnt )
dfs ( i , root , state+1 , j );
if ( p->b[x] )
dfs ( i , p->b[x] , state , j+1 );
}
int main ( )
{
int num = 0;
// freopen ( "a.txt" , "r" , stdin );
root = new Node ( );
while ( ~scanf ( "%s" , s[num] ) )
{
int i = 0;
Node *p = root;
while ( s[num][i] )
{
int x = s[num][i]-'a';
if ( !(p->b[x]) )
p->b[x] = new Node();
p = p->b[x];
i++;
}
p->cnt = 1;
num++;
}
for ( int i = 0 ; i < num ; i++ )
{
flag = false;
dfs ( i , root );
if ( flag )
printf ( "%s\n" , s[i] );
}
}