猜数字


Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3816    Accepted Submission(s): 2724



Problem Description


A有1数m,B来猜.B每猜一次,A就说"太大","太小"或"对了" 。
问B猜n次可以猜到的最大数。


 



Input


第1行是整数T,表示有T组数据,下面有T行
每行一个整数n (1 ≤ n ≤ 30)


 



Output


猜n次可以猜到的最大数


 



Sample Input


2 1 3


 



Sample Output


1 7


 



Author


Zhousc


题目分析:二分法复杂度是log2(n),取逆运算即可

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>

using namespace std;

int t,n;

int main ( )
{
    scanf ( "%d" , &t );
    while ( t-- )
    {
        scanf ( "%d" , &n );
        int h = pow ( 2 , n ) -1;
        printf ( "%d\n" , h );
    }
}




 


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>

using namespace std;

int t,n;

int main ( )
{
    scanf ( "%d" , &t );
    while ( t-- )
    {
        scanf ( "%d" , &n );
        int h = pow ( 2 , n ) -1;
        printf ( "%d\n" , h );
    }
}