438 - The Circumference of the Circle

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=379

To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't?

You are given the cartesian coordinates of three non-collinear points in the plane.

Your job is to calculate the circumference of the unique circle that intersects all three points.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing six real numbers 

 , representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.

Output Specification

For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of  is approximately 3.141592653589793.

Sample Input


0.0 -0.5 0.5 0.0 0.0 0.50.0 0.0 0.0 1.0 1.0 1.0
5.0 5.0 5.0 7.0 4.0 6.0
0.0 0.0 -1.0 7.0 7.0 7.0
50.0 50.0 50.0 70.0 40.0 60.0
0.0 0.0 10.0 0.0 20.0 1.0
0.0 -500000.0 500000.0 0.0 0.0 500000.0


Sample Output

3.144.44
6.28
31.42
62.83
632.24
3141592.65


R=abc/(4S)


完整代码:

/*0.018s*/

#include<cstdio>
#include<cmath>
const double pi = 2 * acos(0);

int main()
{
	double x1, y1, x2, y2, x3, y3, xx1, yy1, xx2, yy2, xx3, yy3;
	while (~scanf("%lf%lf%lf%lf%lf%lf", &x1, &y1, &x2, &y2, &x3, &y3))
	{
		xx1 = x2 - x1, yy1 = y2 - y1, xx2 = x3 - x1, yy2 = y3 - y1, xx3 = x3 - x2, yy3 = y3 - y2;
		printf("%.2f\n", pi * hypot(xx1, yy1)*hypot(xx2, yy2)*hypot(xx3, yy3) / fabs(xx1 * yy2 - xx2 * yy1));
	}
	return 0;
}