10237 - Bishops

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1178

A bishop is a piece used in the game of chess which is played on a board of square grids. A bishop can only move diagonally from its current position and two bishops attack each other if one is on the path of the other. In the following figure, the dark squares represent the reachable locations for bishop B1 form its current position.  The figure also shows that the bishops B1 and B2 are in attacking positions whereas B1 andB3 are not. B2 and B3 are also in non-attacking positions.

 

 

Now, given two numbers n and k, your job is to determine the number of ways one can put k bishops on an n × n chessboard so that no two of them are in attacking positions.

 


Input

 The input file may contain multiple test cases. Each test case occupies a single line in the input file and contains two integers n (1 ≤ n ≤ 30) andk (0 ≤ k ≤ n2).

 

A test case containing two zeros for n and k terminates the input and you won’t need to process this particular input.

 


Output

For each test case in the input print a line containing the total number of ways one can put the given number of bishops on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1015.



Sample Input

8 6
 4 4
 20 40
 30 5
 0 0




Sample Output

5599888
 260
 0
 3127859642656



思路同UVa 861


完整代码:

/*0.049s*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int M = 30 + 5;
const int N = 30 * 30 + 5;

ll Rb[M][N], Rw[M][N], B[M], W[M]; /// B=Black, W=White

void calc(int n, int k, ll R[][N], ll C[])
{
	int i, j;
	memset(R, 0, sizeof(R));
	for (i = 0; i <= n; i++)
		R[i][0] = 1;
	for (i = 1; i <= n; i++)
		for (j = 1; j <= C[i]; j++)
			R[i][j] = R[i - 1][j] + R[i - 1][j - 1] * (C[i] - j + 1);
}

int main()
{
	int i, j, n, k;
	ll ans;
	while (scanf("%d%d", &n, &k), n)
	{
		memset(B, 0, sizeof(B));
		memset(W, 0, sizeof(W));
		for (i = 1; i <= n; i++)
			for (j = 1 ; j <= n; j++)
			{
				if ((i + j) & 1) ++W[(i + j) >> 1];
				else ++B[(i + j) >> 1]; ///计算黑和白的对角线格子数,这样写就不用考虑n的奇偶性
			}
		sort(B + 1, B + n + 1);
		sort(W + 1, W + n);
		calc(n, k, Rb, B);
		calc(n - 1, k, Rw, W);///分别计算白格和黑格上的方案数
		ans = 0;
		for (i = 0; i <= k; i++)
			ans += Rb[n][i] * Rw[n - 1][k - i];
		printf("%lld\n", ans);
	}
	return 0;
}