Dungeon Master


http://poj.org/problem?id=2251



Time Limit:  1000MS


Memory Limit: 65536K




Description



You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 



Input



The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.



Output



Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).



where x is replaced by the shortest time it takes to escape. 


If it is not possible to escape, print the line 


Trapped!



Sample Input



3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0



Sample Output



Escaped in 11 minute(s). Trapped!



Source



Ulm Local 1997




还是vis判断好用!




完整代码:


/*0ms,684KB*/

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int dx[6] = {1, -1, 0, 0, 0, 0};
const int dy[6] = {0, 0, 1, -1, 0, 0};
const int dz[6] = {0, 0, 0, 0, 1, -1};
const int maxn = 35;

struct node
{
	int x, y, z, step;
	node() {}
	node(int a, int b, int c, int d)
	{
		x = a, y = b, z = c, step = d;
	}
} tmp;
queue<node> q;
int n, m, t, x, y, z, i, j, k;
bool vis[maxn][maxn][maxn];
char mp[maxn][maxn][maxn];

bool bfs()
{
	while (!q.empty())
	{
		tmp = q.front();
		q.pop();
		if (mp[tmp.z][tmp.y][tmp.x] == 'E')
		{
			printf("Escaped in %d minute(s).\n", tmp.step);
			return true;
		}
		for (i = 0; i < 6; ++i)
		{
			x = tmp.x + dx[i], y = tmp.y + dy[i], z = tmp.z + dz[i];
			if (mp[z][y][x] != '#' && !vis[z][y][x])
			{
				vis[z][y][x] = true;
				q.push(node(x, y, z, tmp.step + 1));
			}
		}
	}
	return false;
}

int main()
{
	while (~scanf("%d%d%d\n", &t, &n, &m), t)
	{
		memset(vis, 0, sizeof(vis));
		memset(mp, '#', sizeof(mp));
		while (!q.empty()) q.pop();
		for (i = 1; i <= t; ++i)
		{
			for (j = 1; j <= n; ++j)
			{
				for (k = 1; k <= m; ++k)
				{
					mp[i][j][k] = getchar();
					if (mp[i][j][k] == 'S')
					{
						vis[i][j][k] = true;
						q.push(node(k, j, i, 0));
					}
				}
				getchar();
			}
			getchar();
		}
		if (!bfs()) puts("Trapped!");
	}
	return 0;
}