RIPv2
实验4:RIPv2基本配置
1.实验目的
通过本实验可以掌握:
(1)在路由器上启动RIPv2路由进程
(2)启用参与路由协议的接口,并且通告网络
(3)auto-summary的开启和关闭
(4)查看和调试RIPv2路由协议相关信息
2.拓扑结构
实验拓扑如图1-1所示。
3.实验步骤
(1)步骤1:配置路由器 R1
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 1.0.0.0
R1(config-router)#network 192.168.12.0
(2)步骤2:配置路由器 R2
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.12.0
R2(config-router)#network 192.168.23.0
(3)步骤3:配置路由器 R3
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.23.0
R3(config-router)#network 192.168.34.0
(4)步骤4:配置路由器 R4
R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#no auto-summary
R4(config-router)#network 192.168.34.0
R4(config-router)#network 4.0.0.0
4.实验调试
(1) show ip route
R1#show ip route
Codes:C -connected,S-static,R -RIP, M -mobile,B -BGP
D -EIGRP,EX -EIGRPexternal,O -OSPF,IA-OSPF interarea
N1 -OSPF NSSAexternal type1, N2 -OSPF NSSAexternal type2
E1-OSPF external type1, E2-OSPF external type2
i-IS-IS,su-IS-IS summary,L1-IS-IS level-1,L2-IS-IS level-2
ia -IS-IS inter area, *-candidatedefault,U -per-userstaticroute o -ODR, P -periodicdownloaded staticroute
Gatewayoflast resort isnotset
C 192.168.12.0/24isdirectlyconnected,Serial0/0/0
1.0.0.0/24 issubnetted,1subnets
C 1.1.1.0isdirectlyconnected,Loopback0
4.0.0.0/8isvariably subnetted,2subnets,2masks
R 4.4.4.0/24 [120/3]via 192.168.12.2, 00:00:22, Serial0/0/0
R 192.168.23.0/24[120/1]via 192.168.12.2, 00:00:22, Serial0/0/0
R 192.168.34.0/24[120/2]via 192.168.12.2, 00:00:22, Serial0/0/0
从上面输出的路由条目“4.4.4.0/24”,可以看到RIPv2路由更新是携带子网信息的。
(2)show ip protocols
R1#show ipprotocols
RoutingProtocolis"rip"
Outgoingupdate filterlistfor allinterfaces isnotset Incomingupdatefilterlistfor allinterfaces isnotset Sendingupdates every30seconds,nextdue in 19seconds Invalid after 180seconds,holddown 180,flushedafter 240
Redistributing:rip
Defaultversioncontrol: sendversion2, receive version2
Interface Send Recv TriggeredRIP Key-chain
Serial0/0/0 2 2
Loopback0 2 2
// RIPv2默认情况下只接收和发送版本2 的路由更新
【提示】
可以通过命令“ipripsendversion”和“ip ripreceiveversion”来控制在路由 器接口上接收和发送的版本,例如在s0/0/0接口上接收版本1和2的路由更新,但是只发送版本2 的路由更新,配置如下:
R1(config-if)#ip rip send version 2
R1(config-if)#ip rip receive version 1 2
【注意】
接口特性是优于进程特性的,对于本实验,虽然在RIP进程中配置了“version2”, 但是如果在接口上配置了“ip rip receive version 12”,则该接口可以接收版本1 和2 的路由更新。
Automatic network summarization isnotin effect
Maximum path:4
Routingfor Networks
1.0.0.0
192.168.12.0
RoutingInformationSources:
Gateway Distance Last Update
192.168.12.2 120 00:00:26
Distance: (default is120)
实验5:RIPv2手工汇总
1.实验目的
通过本实验可以掌握:
(1)RIPv2路由的手工汇总
(2)RIPv2不支持CIDR 汇总
(3)RIPv2可以传递CIDR汇总
2.拓扑结构
实验拓扑如图5-1所示。
图5-1RIPv2路由手工汇总
3.实验步骤
路由器R1、R2和R3的配置和4.3.1实验4相同,R4的配置如下:
R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#no auto-summary
R4(config-router)#network 192.168.34.0
R4(config-router)#network 4.0.0.0
R4(config)#interface s0/0/0
R4(config-if)#ip summary-addressrip 4.4.0.0255.255.252.0//RIP手工路由汇总
4.实验调试
(1)在没有执行汇总之前路由器R1的路由表如下:
R1#show ip route
Codes:C -connected,S-static,R -RIP, M -mobile,B -BGP
D -EIGRP,EX -EIGRPexternal,O -OSPF,IA-OSPF interarea
N1 -OSPF NSSAexternal type1, N2 -OSPF NSSAexternal type2
E1-OSPF external type1, E2-OSPF external type2
i-IS-IS,su-IS-IS summary,L1-IS-IS level-1,L2-IS-IS level-2
ia -IS-IS inter area, *-candidatedefault,U -per-userstaticroute o -ODR, P -periodicdownloaded staticroute
Gatewayoflast resort isnotset
C 192.168.12.0/24isdirectlyconnected,Serial0/0/0
1.0.0.0/24 issubnetted,1subnets
C 1.1.1.0isdirectlyconnected,Loopback0
4.0.0.0/24 issubnetted,4subnets
R 4.4.0.0 [120/3]via 192.168.12.2, 00:00:21, Serial0/0/0
R 4.4.1.0 [120/3]via 192.168.12.2, 00:00:21, Serial0/0/0
R 4.4.2.0 [120/3]via 192.168.12.2, 00:00:12, Serial0/0/0
R 4.4.3.0 [120/3]via 192.168.12.2, 00:00:05, Serial0/0/0
R 192.168.23.0/24[120/1]via 192.168.12.2, 00:00:21, Serial0/0/0
R 192.168.34.0/24[120/2]via 192.168.12.2, 00:00:22, Serial0/0/0
从上面的输出看到路由器R1的路由表中有R4的4 条环回接口的明细路由。
(2)在执行汇总以后路由器R1的路由表如下:
R1#show ip route
Codes:C -connected,S-static,R -RIP, M -mobile,B -BGP
D -EIGRP,EX -EIGRPexternal,O -OSPF,IA-OSPF interarea
N1 -OSPF NSSAexternal type1, N2 -OSPF NSSAexternal type2
E1-OSPF external type1, E2-OSPF external type2
i-IS-IS,su-IS-IS summary,L1-IS-IS level-1,L2-IS-IS level-2
ia -IS-IS inter area, *-candidatedefault,U -per-userstaticroute o -ODR, P -periodicdownloaded staticroute
Gatewayoflast resort isnotset
C 192.168.12.0/24isdirectlyconnected,Serial0/0/0
1.0.0.0/24 issubnetted,1subnets
C 1.1.1.0isdirectlyconnected,Loopback0
4.0.0.0/22 issubnetted,1subnets
R 4.4.0.0 [120/3]via 192.168.12.2, 00:00:21, Serial0/0/0
R 192.168.23.0/24[120/1]via 192.168.12.2, 00:00:21, Serial0/0/0
R 192.168.34.0/24[120/2]via 192.168.12.2, 00:00:22, Serial0/0/0
上面的输出表明在路由器R1的路由表中接收到汇总路由,当然R2,R3上也能收到汇总 路由。
【思考】
现在将路由器R4 上四个环回接口lo0-lo4 的地址分别修改为192.168.96.4/24,
192.168.97.4/24, 192.168.98.4/24, 192.168.99.4/24,在s0/0/0接口下还能够实现路由 汇总吗?R4上做如下的配置:
R4(config-if)#router rip
R4(config-router)#network 192.168.96.0
R4(config-router)#network 192.168.97.0
R4(config-router)#network 192.168.98.0
R4(config-router)#network 192.168.99.0
R4(config-if)#ip summary-address rip 192.168.96.0255.255.252.0 路由器会提示如下信息:
“Summary mask must be greater orequaltomajor net” 显示的提示信息表明汇总后的掩码长度必须要大于或等于主类网络的掩码程度,因为22<24”,所以不能汇总。
所以RIPv2不支持CIDR汇总,但是可以传递CIDR汇总。 解决方案如下:
(1)用静态路由发布被汇总的路由
R4(config)#ip route192.168.96.0255.255.252.0null0
(2)将静态路由重分布到RIP网络中 R4(config)#router rip
R4(config-router)#redistribute static //将静态路由重分布到RIP路由协议中R4(config-router)#no network192.168.96.0
R4(config-router)#no network192.168.97.0
R4(config-router)#no network192.168.98.0
R4(config-router)#no network192.168.99.0
(3)在路由器R1上查看路由表
R1#show ip route
Codes:C -connected,S-static,R -RIP, M -mobile,B -BGP
D -EIGRP,EX -EIGRPexternal,O -OSPF,IA-OSPF interarea
N1 -OSPF NSSAexternal type1, N2 -OSPF NSSAexternal type2
E1-OSPF external type1, E2-OSPF external type2
i-IS-IS,L1-IS-IS level-1,L2-IS-IS level-2,ia -IS-IS inter area
*-candidatedefault,U -per-userstaticroute, o -ODR P -periodicdownloaded staticroute
Gatewayoflast resort isnotset
C 192.168.12.0/24isdirectlyconnected,Serial0/0/0
1.0.0.0/24 issubnetted,1subnets
C 1.1.1.0isdirectlyconnected,Loopback0
R 192.168.23.0/24[120/1]via 192.168.12.2, 00:00:18, Serial0/0/0
R 192.168.34.0/24[120/2]via 192.168.12.2, 00:00:18, Serial0/0/0
R 192.168.96.0/22 [120/3]via 192.168.12.2, 00:00:18, Serial0/0/0
通过输出不难看出RIPv2是可以传递CIDR汇总信息的。