Description



Given a set of digits S, and an integer n, you have to find how many n-digit integers are there, which contain digits that belong to S and the difference between any two adjacent digits is not more than two.


Input



Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case contains two integers, m (1 ≤ m < 10) and n (1 ≤ n ≤ 10). The next line will contain m integers (from 1 to 9) separated by spaces. These integers form the set S as described above. These integers will be distinct and given in ascending order.


Output



For each case, print the case number and the number of valid n-digit integers in a single line.


Sample Input



3
3 2
1 3 6
3 2
1 2 3
3 3
1 4 6


Sample Output



Case 1: 5

Case 2: 9

Case 3: 9

/*定义dp[i][j]为长为i位以第j个数结尾的满足题意的方案数*/
#include <iostream>
#include <cstdio>
#include <cmath>
#include <stack>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 20;
int a[N];
int dp[N][N];

int main()
{
    int t, n, m, x = 0;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        for(int i = 1; i <= n; i++)
            scanf("%d", a + i);

        memset(dp, 0, sizeof dp);
        for(int i = 1; i <= n; i++)
            dp[1][i] = 1;
        for(int i = 2; i <= m; i++)
            for(int j = 1; j <= n; j++)
                for(int k = 1; k <= n; k++)
                    if(abs(a[j] - a[k]) <= 2)
                        dp[i][j] += dp[i-1][k];
        int res = 0;
        for(int i = 1; i <= n; i++)
            res += dp[m][i];
        printf("Case %d: %d\n", ++x, res);
    }


    return 0;
}