Mohe_R1#sh run
Building configuration...
Current configuration : 4796 bytes
!
version 12.4
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service dhcp
!
hostname Mohe_R1
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 informational
enable secret 5 $1$4Ei0$IZ20rm/dg.g2/JfytmFVe1
!
aaa new-model
aaa local authentication attempts max-fail 3
!
!
aaa authentication login default local
!
!
aaa session-id common
no network-clock-participate wic 0
no ip source-route
!
!
ip cef
ip dhcp bootp ignore
!
!
no ip domain lookup        //关掉域名查找
ip domain name yourdomain.com
multilink bundle-name authenticated
!
!
key chain key-hsrp       //密钥链 名
 key 1                 //密钥编号
   key-string 7 1307181508        //定义密钥
key chain key-eigrp        //密钥链 名  
 key 2                      //密钥编号
   key-string 7 110B160214    //定义密钥
!
!
memory reserve critical 10000
memory free low-watermark processor 2000
memory free low-watermark IO 2000
!
spanning-tree vlan 1 priority 8192
username bogc secret 5 $1$x/WC$J.Z75osNsp/aFgpS6HJO8/
archive
 log config
  hidekeys
!
!
controller E1 0/0/0
!
controller E1 0/0/1
!
!
!
!        
interface Loopback1
 ip address 172.30.56.1 255.255.255.255
!
interface FastEthernet0/0
 description connect beijing SDH
 bandwidth 10000
 ip address 172.30.58.2 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip authentication mode eigrp 185 md5
 ip authentication key-chain eigrp 185 key-eigrp
 delay 100
 duplex full
 speed 100
!
interface FastEthernet0/1
 description connect langfang SDH
 bandwidth 10000
 ip address 172.30.61.2 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip authentication mode eigrp 185 md5         //声明验证模式
 ip authentication key-chain eigrp 185 key-eigrp        //在需要执行路由信息验证更新的接口上应用密钥链
 delay 100
 duplex full
 speed 100
!
interface FastEthernet0/1/0
 description connect sw1-1
 duplex full
 speed 100
!
interface FastEthernet0/1/1
 description connect sw2-1
 duplex full
 speed 100
!
interface FastEthernet0/1/2
 switchport access vlan 2
!
interface FastEthernet0/1/3
!
interface Vlan1
 ip address 172.18.48.60 255.255.255.192
 no ip redirects
 no ip proxy-arp
 standby 10 ip 172.18.48.62
 standby 10 timers 2 6
 standby 10 priority 110
 standby 10 preempt
 standby 10 authentication md5 key-chain key-hsrp
!
interface Vlan2
 ip address 172.30.57.1 255.255.255.252
!
router eigrp 185
 passive-interface Vlan1
 network 172.18.48.0 0.0.0.63
 network 172.30.56.1 0.0.0.0
 network 172.30.57.0 0.0.0.3
 network 172.30.58.0 0.0.0.3
 network 172.30.61.0 0.0.0.3
 no auto-summary           //取消自动汇总
 eigrp stub connected leak-map leak-core-route
!        
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.18.48.61 200
!
!
no ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 20 permit 172.16.33.0 0.0.0.255
access-list 20 permit 172.16.97.0 0.0.0.255
access-list 30 permit 172.16.33.0 0.0.0.255
access-list 30 permit 172.16.97.0 0.0.0.255
snmp-server community petrData RO 10
route-map leak-core-route permit 30
 match ip address 30
!
!
!
control-plane
!
banner exec ^C  //登录信息
% Password expiration warning.
----------
----------
^C
banner login ^C
---------------
---------------
^C
!
line con 0
line aux 0
line vty 0 4
 exec-timeout 3 0
 privilege level 15
 transport input telnet
line vty 5 15
 privilege level 15
 transport input telnet
!
scheduler allocate 20000 1000
!
end
Mohe_R1#