uva 357 Let Me Count The Ways
After making a purchase at a large department store, Mel's change was 17 cents. He received 1 dime, 1 nickel, and 2 pennies. Later that day, he was shopping at a convenience store. Again his change was 17 cents. This time he received 2 nickels and 7 pennies. He began to wonder ' "How many stores can I shop in and receive 17 cents change in a different configuration of coins? After a suitable mental struggle, he decided the answer was 6. He then challenged you to consider the general problem.
Write a program which will determine the number of different combinations of US coins (penny: 1c, nickel: 5c, dime: 10c, quarter: 25c, half-dollar: 50c) which may be used to produce a given amount of money.
Input
The input will consist of a set of numbers between 0 and 30000 inclusive, one per line in the input file.
Output
The output will consist of the appropriate statement from the selection below on a single line in the output file for each input value. The number m is the number your program computes, n is the input value.
There are mways to produce ncents change.
There is only 1 way to produce ncents change.
Sample input
17 11 4
Sample output
There are 6 ways to produce 17 cents change. There are 4 ways to produce 11 cents change. There is only 1 way to produce 4 cents change.
题目大意:给出一个金额数。要求求出用5种面值能够组成该金额数的方法数。
解题思路:注意输出时,当方法数为1时,要特判。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
typedef long long ll;
using namespace std;
int coin[5] = {1, 5, 10, 25, 50};
ll dp[30000];
int main() {
int n;
while (scanf("%d", &n) == 1) {
memset(dp, 0, sizeof(dp));
dp[0] = 1;
for (int i = 0; i < 5; i++) {
for (int j = coin[i]; j <= n; j++) {
if (dp[j - coin[i]]) {
dp[j] += dp[j - coin[i]];
}
}
}
if (dp[n] == 1) {
printf("There is only 1 way to produce %d cents change.\n", n);
}
else printf("There are %lld ways to produce %d cents change.\n", dp[n], n);
}
return 0;
}