uva 311 Packets


A factory produces products packed in square packets of the same height h and of the sizes

,

,

,

,

,

. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size

. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size

to the biggest size

. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input


0 0 4 0 0 17 5 1 0 0 00 0 0 0 0 0


Sample Output


21



题目大意:6种行李1*1, 2*2, 3*3, 4*4, 5*5, 6*6,要将它们装在6*6的箱子中,问最少需要几个箱子。

解题思路:贪心。

①每个6*6的行李占一个箱子。
②每个5*5的行李放在一个箱子里,同时里面还能装11个1*1的行李。
③每个4*4的行李放在一个箱子里,同时里面还能装5个2*2的行李,如果2*2的不够了,那么还能放1*1的行李。
④每4个3*3的行李放在一个箱子里,则要视情况而定。
⑤最后如果还剩下了2*2和1*1的行李,再考虑1*1和2*2。


#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
using namespace std;
int main() {
	int a, b, c, d, e, f;
	while (scanf("%d %d %d %d %d %d", &a, &b, &c, &d, &e, &f) == 6) {
		if (a == 0 && b == 0 && c == 0 && d == 0 && e == 0 && f == 0) break;
		int ans;
		ans = f + e + d + c / 4;
		a -= 11 * e;
		b -= 5 * d;
		if (c % 4 == 1) {
			b -= 5;
			a -= 7;
			ans++;
		}
		else if (c % 4 == 2) {
			b -= 3;
			a -= 6;
			ans++;
		}
		else if (c % 4 == 3) {
			b -= 1;
			a -= 5;
			ans++;
		}

		if (b < 0) {
			a += 4 * b;
			b = 0;
		}
		if (a < 0)  a = 0;
		ans += ceil((a + 4 * b) / 36.0);
		printf("%d\n", ans);
	}
	return 0;
}