ACDREAM 03B New Year Bonus Grant

Problem Description
All programmers of Mocrosoft software company are organized in a strict subordination hierarchy. Every programmer has exactly one chief, except Bill Hates who is also the head of the company and has no chief.
Due to the celebration of the new 2003 year, chief accountant of Mocrosoft decided to pay a New Year Bonus Grant of 1000 dollars to some programmers. However being extremely concerned of the company wealth she would like to designate the least possible amount of money for these grants. On the other hand she didn’t want to be accused of being too greedy or of giving preferences to some programmers. To do this, she developed the following scheme of grants appointment:
• Each programmer may either assign a grant to one of his subordinates or have a grant assigned to him by his chief or none of the above.
• No programmer can simultaneously receive a grant and assign a grant to one of his subordinates.
• No programmer can assign a grant to more than one of his subordinates
The scheme seemed to be designed perfectly — nobody would like to assign a grant to anybody since in this case he himself would not receive money. But programmers somehow discovered the plan of chief accountant and decided to make a trick to get the most money possible and share them fairly afterwards. The idea was to make such grant assignments that the total amount of grant money received is maximum possible.
You were selected to write the program which will find the optimal grants appointment.
Input
The first line of the input file contains integer N — the number of programmers in Mocrosoft company (2 ≤ N ≤ 500 000). Each programmer is assigned his unique identifier — integer number ranging from 1 to N . Bill Hates has number 1 and each programmer has the number greater then the number of his chief. The second line of the input file contains N − 1 integers, i-th of which being the number of the chief of the worker whose number is (i + 1).
Output
On the first line of the output file print the maximum possible amount of money workers can get. On the second line output the numbers of programmers that will receive grant in ascending order.
Sample Input

4
1 1 2

Sample Output

2000
3 4

题目大意:输入包括两个部分:整数N代表有N个人,每个人都有编号从1~N,接下来一行有N-1个数,第i个数代表的是第i+1个人的父亲的编号。 每个人可以有两个操作:接受父亲的奖金或者给儿子奖金(出了根节点)。当进行了一次任意操作后,就不可以在进行操作。

解题思路:思路:问题转化为给一颗树染色:(1)每一个节点至多只有一个儿子被染色(2)如果某个节点被染色,那么它的所有儿子都不能染色(也就是一个节点如果染色了,他的父亲,兄弟,儿子都不能染色)

样例分析图:

ACDREAM 03B New Year Bonus Grant(贪心专场)_#define

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;
#define N 500005
typedef long long ll;
int fa[N], vis[N], ans[N];
int main() {
    int n;
    while (scanf("%d", &n) != EOF) {
        for (int i = 2; i <= n; i++) {
            scanf("%d", &fa[i]);
        }
        memset(vis, 0, sizeof(vis));
        int cnt = 0;
        for (int i = n; i > 1; i--) {
            if (!vis[i] && !vis[fa[i]]) {
                vis[i] = vis[fa[i]] = 1;
                ans[cnt++] = i;
            }
        }
        printf("%d\n", cnt * 1000);
        printf("%d", ans[cnt - 1]);
        for (int i = cnt - 2; i >= 0; i--) {
            printf(" %d", ans[i]);
        }
        printf("\n");
    }   
    return 0;
}