BGP综合实验

网络安全架构与部署-高级路由-BGP(BGP综合实验)20210928_网络安全

实验作业:

按要求部署实验环境

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-9GlZZnlc-1632761026166)(/Users/aron/Documents/51ctoallstacksec/RegularWork/BGP综合实验/bgp - router bgp/截图.png)]

\1. 要求根据图中IP地址规划,实现底层连通性;

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s0/0
R1(config-if)#ip add 12.1.1.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#int s0/1
R1(config-if)#ip add 17.1.1.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#int lo1
R1(config-if)#ip add 1.1.1.1 255.255.255.255
R1(config-if)#end
R1#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  12.1.1.1        YES manual up                    down    
Serial0/1                  17.1.1.1        YES manual up                    down    
Serial0/2                  unassigned      YES unset  administratively down down    
Serial0/3                  unassigned      YES unset  administratively down down    
Loopback1                  1.1.1.1         YES manual up                    up      



R2#conf t  
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int s0/0
R2(config-if)#ip add 12.1.1.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#int f1/0
R2(config-if)#ip add 10.1.23.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#int f2/0
R2(config-if)#ip add 10.1.25.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#int lo1
R2(config-if)#ip add 2.2.2.2 255.255.255.255
R2(config-if)#end
 
R2#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  12.1.1.2        YES manual up                    up      
Serial0/1                  unassigned      YES unset  administratively down down    
Serial0/2                  unassigned      YES unset  administratively down down    
Serial0/3                  unassigned      YES unset  administratively down down    
FastEthernet1/0            10.1.23.2       YES manual up                    up      
FastEthernet2/0            10.1.25.2       YES manual up                    up      
Loopback1                  2.2.2.2         YES manual up                    up      
R2#


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#int f0/0
R3(config-if)#ip add 10.1.23.3 255.255.255.0
R3(config-if)#no sh
R3(config-if)#int f1/0
R3(config-if)#ip add 10.1.34.3 255.255.255.0
R3(config-if)#int lo1
R3(config-if)#ip add 3.3.3.3 255.255.255.255
R3(config-if)#end

R3#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.1.23.3       YES manual up                    up      
FastEthernet1/0            10.1.34.3       YES manual administratively down down    
Loopback1                  3.3.3.3         YES manual up                    up      
R3#


R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#int f0/0
R4(config-if)#ip add 10.1.34.4 255.255.255.0
R4(config-if)#no sh
R4(config-if)#int f1/0
R4(config-if)#ip add 10.1.45.4 255.255.255.0
R4(config-if)#no sh
R4(config)#int lo1
R4(config-if)#ip add 4.4.4.4 255.255.255.255
R4(config)#int s2/0
R4(config-if)#ip add 46.1.1.4 255.255.255.0  
R4(config-if)#no sh
R4(config-if)#end

R4#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.1.34.4       YES manual up                    up      
FastEthernet1/0            10.1.45.4       YES manual up                    up      
Serial2/0                  unassigned      YES unset  administratively down down    
Serial2/1                  unassigned      YES unset  administratively down down    
Serial2/2                  unassigned      YES unset  administratively down down    
Serial2/3                  unassigned      YES unset  administratively down down    
Loopback1                 4.4.4.4         YES manual up                    up      

R4#ping 10.1.34.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.34.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 20/22/28 ms
R4#

R4#ping 46.1.1.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 46.1.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/24 ms
R4#



R5#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#int f0/0
R5(config-if)#ip add 10.1.45.5 255.255.255.0
R5(config-if)#no sh
R5(config-if)#int f1/0
R5(config-if)#ip add 10.1.25.5 255.255.255.0
R5(config-if)#no sh
R5(config-if)#int lo1 
R5(config-if)#ip add 5.5.5.5 255.255.255.255
R5(config-if)#end


R5#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.1.45.5       YES manual up                    up      
FastEthernet1/0            10.1.25.5       YES manual up                    up      
Loopback1                  5.5.5.5         YES manual up                    up      

R5#ping 10.1.45.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.45.4, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 12/16/20 ms
R5#ping 10.1.25.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.25.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 16/24/40 ms
R5#ping 5.5.5.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R5#

R6同理

R7#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#int lo1
R7(config-if)#ip add 7.7.7.7 255.255.255.255
R7(config-if)#int s0/1
R7(config-if)#ip add 17.1.1.1 255.255.255.0
R7(config-if)#no sh
R7(config-if)#int s0/0
R7(config-if)#no sh
R7(config-if)#ip add 67.1.1.7 255.255.255.0
R7(config-if)#end

R7#show ip int br 
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  67.1.1.7        YES manual up                    up      
Serial0/1                  17.1.1.1        YES manual up                    up      
Serial0/2                  unassigned      YES unset  administratively down down    
Serial0/3                  unassigned      YES unset  administratively down down    
Loopback1                  7.7.7.7         YES manual up                    up      

R7#ping 67.1.1.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 67.1.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/20/32 ms
R7#ping 17.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 17.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/24/52 ms
R7#ping 7.7.7.7

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R7#

\2. 要求在BGP的AS2345内部运行OSPF保证底层可达;

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router ospf 100
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
R2(config-router)#network 10.1.23.0 0.0.0.255 area 0
R2(config-router)#network 10.1.25.0 0.0.0.255 area 0
R2(config-router)#
*Mar  1 02:01:58.327: %OSPF-5-ADJCHG: Process 100, Nbr 3.3.3.3 on FastEthernet1/0 from LOADING to FULL, Loading Done


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 100
R3(config-router)#router-id 3.3.3.3
R3(config-router)#netw
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0
R3(config-router)#network 10.1.23.0 0.0.0.255 area 0
R3(config-router)#network 10.1.34.0 0.0.0.255 area 0
R3(config-router)#
*Mar  1 02:01:54.115: %OSPF-5-ADJCHG: Process 100, Nbr 2.2.2.2 on FastEthernet0/0 from LOADING to FULL, Loading Done

R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#router ospf 100
R4(config-router)#network 4.4.4.4 0.0.0.0 area 0
R4(config-router)#network 10.1.34.0 0.0.0.255 area 0
R4(config-router)#network 10.1.45.0 0.0.0.255 area 


R5同理

测试ospf的底层可达性等:

R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/BDR        00:00:30    10.1.23.3       FastEthernet1/0
R2#show ip route ospf
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 10.1.23.3, 00:01:11, FastEthernet1/0


R2#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/21/32 ms
R2#ping 4.4.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/38/68 ms
R2#ping 5.5.5.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/17/28 ms


R2#show ip route ospf
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 10.1.23.3, 00:02:00, FastEthernet1/0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/3] via 10.1.25.5, 00:02:00, FastEthernet2/0
                [110/3] via 10.1.23.3, 00:02:00, FastEthernet1/0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/2] via 10.1.25.5, 00:02:00, FastEthernet2/0
     10.0.0.0/24 is subnetted, 4 subnets
O       10.1.45.0 [110/2] via 10.1.25.5, 00:02:00, FastEthernet2/0
O       10.1.34.0 [110/2] via 10.1.23.3, 00:02:00, FastEthernet1/0


R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
5.5.5.5           1   FULL/BDR        00:00:30    10.1.25.5       FastEthernet2/0
3.3.3.3           1   FULL/BDR        00:00:36    10.1.23.3       FastEthernet1/0


R2#show ip ospf database 

            OSPF Router with ID (2.2.2.2) (Process ID 100)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
2.2.2.2         2.2.2.2         144         0x80000006 0x00F768 3
3.3.3.3         3.3.3.3         228         0x80000005 0x002917 3
4.4.4.4         4.4.4.4         157         0x80000005 0x00966D 3
5.5.5.5         5.5.5.5         145         0x80000005 0x0039CF 3

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.23.2       2.2.2.2         456         0x80000001 0x009D5C
10.1.25.2       2.2.2.2         144         0x80000001 0x00EB04
10.1.34.3       3.3.3.3         228         0x80000001 0x005091
10.1.45.4       4.4.4.4         157         0x80000001 0x0003C6
R2#

\3. 依据图中AS设计,运行BGP协议,实现AS之间互联;

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router bgp 100
R1(config-router)#no auto-summary 
R1(config-router)#no synchronization 
R1(config-router)#bgp router-id 1.1.1.1
R1(config-router)#neighbor 12.1.1.2 remote-as 2345
R1(config-router)#neighbor 17.1.1.7 remote-as 700
R1(config-router)#network 1.1.1.1 mask 255.255.255.255


R2#show ip route bgp
     1.0.0.0/32 is subnetted, 1 subnets
B       1.1.1.1 [20/0] via 12.1.1.1, 00:01:56
R2#

R1#show run | s r b
router bgp 100
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 12.1.1.2 remote-as 2345
 no auto-summary
 

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router bgp 2345
R2(config-router)#bgp router-id 2.2.2.2
R2(config-router)#no auto-summary 
R2(config-router)#no synchronization 
R2(config-router)#neighbor 12.1.1.1 remote-as 100
R2(config-router)#end


IBGP:
R2(config)#router bgp 2345
R2(config-router)#neighbor 3.3.3.3 remote-as 2345
R2(config-router)#neighbor 3.3.3.3 update-source loopback 1
R2(config-router)#neighbor 5.5.5.5 remote-as 2345
R2(config-router)#neighbor 5.5.5.5 update-source loopback 1
R2(config-router)#


R1#show ip route bgp
     2.0.0.0/32 is subnetted, 1 subnets
B       2.2.2.2 [20/0] via 12.1.1.2, 00:00:14
R1#

R1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/28 ms
R1#


IBGP:
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router bgp 2345
R3(config-router)#no synchronization 
R3(config-router)#no auto-summary 
R3(config-router)#neighbor 2.2.2.2 remote-as 2345
R3(config-router)#neighbor 2.2.2.2 update-source loopback 1
R3(config-router)#neighbor 4.4.4.4 remote-as 2345
R3(config-router)#neighbor 4.4.4.4 update-source loopback 1
R3(config-router)#


R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#router bgp 2345
R4(config-router)#no auto-summary 
R4(config-router)#no synchronization 
R4(config-router)#bgp router-id 4.4.4.4
R4(config-router)#neighbor 46.1.1.6 remote-as 600
R4(config-router)#network 4.4.4.4 mask 255.255.255.255
R4(config-router)#

IBGP:
R4#conf t
R4(config)#router bgp 2345
R4(config-router)#neighbor 3.3.3.3 remote-as 2345
R4(config-router)#neighbor 3.3.3.3 update-source loopback 1
R4(config-router)#neighbor 5.5.5.5 remote-as 2345
R4(config-router)#neighbor 5.5.5.5 update-source loopback 1

R5#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#router bgp 2345
R5(config-router)#no synchronization 
R5(config-router)#no auto-summary 
R5(config-router)#bgp router 5.5.5.5
R5(config-router)#neighbor 2.2.2.2 remote-as 2345
R5(config-router)#neighbor 2.2.2.2 update-source loopback 1
R5(config-router)#neighbor 4.4.4.4 remote-as 2345
R5(config-router)#neighbor 4.4.4.4 update-source loopback 1


R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#router bgp 600
R6(config-router)#no auto-summary 
R6(config-router)#no synchronization 
R6(config-router)#bgp router-id 6.6.6.6
R6(config-router)#neighbor 46.1.1.4 remote-as 2345
R6(config-router)#neighbor 67.1.1.7 remote-as 700
*Mar  1 02:16:34.023: %BGP-5-ADJCHANGE: neighbor 46.1.1.4 Up 
R6(config-router)#network 6.6.6.6 mask 255.255.255.255


R7#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#router bgp 700
R7(config-router)#no auto-summary 
R7(config-router)#no synchronization 
R7(config-router)#bgp router-id 7.7.7.7   
R7(config-router)#neighbor 67.1.1.6 remote-as 600
R7(config-router)#neighbor 17.1.1.1 remote-as 100
R7(config-router)#network 7.7.7.7 mask 255.255.255.255
R7(config-router)#end





查询验证:
R1#show run | s r b
router bgp 100
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 12.1.1.2 remote-as 2345
 neighbor 17.1.1.7 remote-as 700
 no auto-summary

R1#show ip bgp summary 
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 6, main routing table version 6
5 network entries using 585 bytes of memory
5 path entries using 260 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1685 total bytes of memory
BGP activity 5/0 prefixes, 5/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
12.1.1.2        4  2345      62      65        6    0    0 00:57:17        1
17.1.1.7        4   700      15      15        6    0    0 00:06:05        3
R1#show ip bgp
BGP table version is 6, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       0.0.0.0                  0         32768 i
*> 2.2.2.2/32       12.1.1.2                 0             0 2345 i
*> 4.4.4.4/32       17.1.1.7                               0 700 600 2345 i
*> 6.6.6.6/32       17.1.1.7                               0 700 600 i
*> 7.7.7.7/32       17.1.1.7                 0             0 700 i
R1#show ip route bgp
     2.0.0.0/32 is subnetted, 1 subnets
B       2.2.2.2 [20/0] via 12.1.1.2, 00:48:28
     4.0.0.0/32 is subnetted, 1 subnets
B       4.4.4.4 [20/0] via 17.1.1.7, 00:04:57
     6.0.0.0/32 is subnetted, 1 subnets
B       6.6.6.6 [20/0] via 17.1.1.7, 00:04:57
     7.0.0.0/32 is subnetted, 1 subnets
B       7.7.7.7 [20/0] via 17.1.1.7, 00:06:22
R1#



R3#show ip bgp summary
BGP router identifier 3.3.3.3, local AS number 2345
BGP table version is 8, main routing table version 8
5 network entries using 585 bytes of memory
8 path entries using 416 bytes of memory
8/1 BGP path/bestpath attribute entries using 992 bytes of memory
6 BGP AS-PATH entries using 144 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2137 total bytes of memory
BGP activity 5/0 prefixes, 9/1 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4  2345      36      32        8    0    0 00:28:26        4
4.4.4.4         4  2345      37      31        8    0    0 00:27:00        4
R3#


R2#show ip bgp summary 
BGP router identifier 2.2.2.2, local AS number 2345
BGP table version is 5, main routing table version 5
4 network entries using 468 bytes of memory
4 path entries using 208 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1368 total bytes of memory
BGP activity 4/0 prefixes, 4/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.3.3.3         4  2345      32      36        5    0    0 00:28:04        0
5.5.5.5         4  2345      27      31        5    0    0 00:23:38        0
12.1.1.1        4   100      41      35        5    0    0 00:31:59        3
R2#

\4. 要求在R1、R7、R6上通告环回接口,并要求能相互学习到其路由,并带源Ping通。

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ip route 2.2.2.2 255.255.255.255 s0/0
R1(config)#ip route 7.7.7.7 255.255.255.255 s0/1
R1(config)#router bgp 100
R1(config-router)#neighbor 2.2.2.2 remote-as 2345
R1(config-router)#neighbor 2.2.2.2 ebgp-multihop 2
R1(config-router)#neighbor 2.2.2.2 update-source loopback 1
R1(config-router)#neighbor 7.7.7.7 remote-as 700
R1(config-router)#neighbor 7.7.7.7 ebgp-multihop 2
R1(config-router)#neighbor 7.7.7.7 update-source loopback 1
R1(config-router)#exit

R1(config)#end
R1#
*Mar  1 01:01:56.835: %SYS-5-CONFIG_I: Configured from console by console
R1#


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ip route 1.1.1.1 255.255.255.255 s0/0
R2(config)#router bgp 2345
R2(config-router)#neighbor 1.1.1.1 remote-as 100
R2(config-router)#neighbor 1.1.1.1 ebgp-multihop 2
R2(config-router)#neighbor 1.1.1.1 update-source loopback 1
R2(config-router)#
*Mar  1 01:04:37.871: %BGP-5-ADJCHANGE: neighbor 1.1.1.1 Up 
R2(config-router)#


R7#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R7(config)#ip route 6.6.6.6 255.255.255.255 s0/0
R7(config)#ip route 1.1.1.1 255.255.255.255 s0/1
R7(config)#router bgp 700
R7(config-router)#neighbor 1.1.1.1 remote-as 100    
R7(config-router)#neighbor 1.1.1.1 ebgp-multihop 2
*Mar  1 01:06:44.267: %BGP-5-ADJCHANGE: neighbor 1.1.1.1 Up 
R7(config-router)#neighbor 1.1.1.1 update-source loopback 1
R7(config-router)#neighbor 6.6.6.6 remote-as 600
R7(config-router)#neighbor 6.6.6.6 ebgp-multihop 2
R7(config-router)#neighbor 6.6.6.6 update-source loopback 1
R7(config-router)#


R4#conf t
R4(config)#ip route 6.6.6.6 255.255.255.255 s2/0
R4(config)#router bgp 2345
R4(config-router)#neighbor 6.6.6.6 remote-as 600
R4(config-router)#neighbor 6.6.6.6 ebgp-multihop 2
R4(config-router)#neighbor 6.6.6.6 update-source loopback 1
R4(config)#end



R4#show ip route bgp
     1.0.0.0/32 is subnetted, 1 subnets
B       1.1.1.1 [20/0] via 6.6.6.6, 00:00:00
     7.0.0.0/32 is subnetted, 1 subnets
B       7.7.7.7 [20/0] via 6.6.6.6, 00:00:00
R4#ping 1.1.1.1 source 4.4.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 4.4.4.4 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/50/76 ms
R4#ping 7.7.7.7 source 4.4.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
Packet sent with a source address of 4.4.4.4 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/33/44 ms
R4#

R1#ping 6.6.6.6 source 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/33/48 ms
R1#

【作业要求】
1、用GNS3搭建拓扑,并根据要求完成项目;
2、将整个GNS3项目文件打包为压缩包,并以附件上传,压缩包的名称规范为“姓名-BGP综合实验”。
***编写实验报告,将整个作业过程中的涉及的步骤、效果、思路等整理为Word或PDF或PPT文档并上传,文档名称为"姓名-作业名称"。