Oil Deposits

Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
* *@
@@@
@*@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

题解

求图中连通的个数,直接遇到@就dfs即可,将已经访问过的做个标记

代码

#include<iostream>
#include<string>
#include<cstring>
#include<stdlib.h>
#include<memory.h>
using namespace std;

char map[105][105];
int idx[105][105];
int m, n;

void dfs(int r, int c,int id);

int main()
{
    while (cin >> m >> n)
    {
        if (m==0 && n==0)
            break;
        memset(map,0,sizeof(map));
        memset(idx,0,sizeof(idx));
        for (int i = 0; i < m;i++)
        for (int j = 0; j < n; j++)
            cin >> map[i][j];
        int cnt = 0;
        for (int i = 0; i < m;i++)
        for (int j = 0; j < n; j++)
        {
            if (idx[i][j] == 0 && map[i][j] == '@')
            {
                dfs(i, j,++cnt);
            }
        }
        cout << cnt << endl;
    }
}

void dfs(int r ,int c,int id)
{

    if (r < 0 || r >= m || c < 0 || c >= n)
        return;
    if (idx[r][c] >0 || map[r][c] != '@')
        return;
    idx[r][c] = id;
    for (int dr = -1; dr <= 1;dr++)
    for (int dc = -1; dc <= 1;dc++)
    if (dr != 0 || dc != 0)
        dfs(r + dr,c + dc,id);
}