当你在社交网络平台注册时,一般总是被要求填写你的个人兴趣爱好,以便找到具有相同兴趣爱好的潜在的朋友。一个“社交集群”是指部分兴趣爱好相同的人的集合。你需要找出所有的社交集群。
输入格式:
输入在第一行给出一个正整数 N(≤1000),为社交网络平台注册的所有用户的人数。于是这些人从 1 到 N 编号。随后 N 行,每行按以下格式给出一个人的兴趣爱好列表:
Ki: hi[1] hi[2] … hi[Ki]
其中Ki(>0)是兴趣爱好的个数,hi[j]是第j个兴趣爱好的编号,为区间 [1, 1000] 内的整数。
输出格式:
首先在一行中输出不同的社交集群的个数。随后第二行按非增序输出每个集群中的人数。数字间以一个空格分隔,行末不得有多余空格。
输入样例:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
输出样例:
3
4 3 1
这道题我用的并查集模板也就是unionsearch()和join()两个函数,这道题还是蛮简单的,毕竟只考察了并查集,却竟然是一道3阶题
//
// Created by TIGA_HUANG on 2020/10/5.
//
#include <iostream>
#include <set>
#include <map>
#include <algorithm>
using namespace std;
int pre[1010]; //存放第i个元素的父节点
int unionsearch(int root) //查找根结点
{
int son, tmp;
son = root;
while (root != pre[root]) //寻找根结点
root = pre[root];
while (son != root) //路径压缩
{
tmp = pre[son];
pre[son] = root;
son = tmp;
}
return root;
}
void join(int root1, int root2) //判断是否连通,不连通就合并
{
int x, y;
x = unionsearch(root1);
y = unionsearch(root2);
if (x != y) //如果不连通,就把它们所在的连通分支合并
pre[x] = y;
}
int main() {
int N;
cin >> N;
for (int i = 0; i < 1010; ++i) {
pre[i] = i;
}
int f[1010] = {};
for (int i = 1; i <= N; ++i) {
int k;
scanf("%d:", &k);
int t;
int pre2;
cin >> pre2;
f[i] = pre2;
for (int j = 1; j < k; ++j) {
cin >> t;
join(pre2, t);
}
}
set<int> s;
int ans = 0;
map<int, int> mp;
for (int i = 1; i <= N; ++i) {
mp[unionsearch(f[i])]++;
}
cout << mp.size() << '\n';
int *anss = new int[N + 1];
int idx = 0;
for (auto it = mp.begin(); it != mp.end(); ++it) {
anss[idx++] = it -> second;
}
sort(anss, anss + idx);
reverse(anss, anss + idx);
for (int l = 0; l < idx; ++l) {
if (l)
cout << ' ';
cout << anss[l];
}
return 0;
}