数据结构实验之链表六:有序链表的建立

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

Input

第一行输入整数个数N;
第二行输入N个无序的整数。

Output

依次输出有序链表的结点值。

Sample Input


6 33 6 22 9 44 5


Sample Output


5 6 9 22 33 44


Hint

不得使用数组!

Source

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
    struct node *head, *p, *tail, *q;
    int n, i, t;
    scanf("%d", &n);
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    for(i = 1; i <= n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p->data);
        p->next = NULL;
        tail->next = p;
        tail = p;
    }
   for(p = head->next; p != NULL; p = p->next)
   {
       for(q = p->next; q != NULL; q = q->next)
       {
           if(p->data > q->data)
           {
               t = q->data;
               q->data = p->data;
               p->data = t;
           }
       }
   }
    for(p = head->next; p->next != NULL; p = p->next)
    {
        printf("%d ", p->data);
    }
    printf("%d\n", p->data);
    return 0;
}