For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,104).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

解题思路:

将一个数的从大到小排序减去从小到大排序,值赋给这个数,依次循环直到得到6174或者0

这题的注意点是如果输入的数或者得到的值不足4位数的话,要用0补足

这题用string就可以解决,利用stoi和to_string函数互相转换

#include <iostream>
#include <algorithm>
#include <string>
using namespace std;

bool cmpMAx(char a, char b) {
	return a > b;
}
bool cmpMin(char a, char b) {
	return a < b;
}
string num;
int main() {
	cin >> num;
	int res = -1;
	string maxsnum, minsnum;
	while (true) {
		if (num.length() < 4) {
			for (int j = num.length(); j < 4; ++j) {
				num += '0';
			}
		}
		sort(num.begin(), num.end(), cmpMAx);
		maxsnum = num;
		sort(num.begin(), num.end(), cmpMin);
		minsnum = num;
		res = stoi(maxsnum) - stoi(minsnum);
		printf("%04d - %04d = %04d\n", stoi(maxsnum), stoi(minsnum), res);
		if(res == 0 || res == 6174) break;
		num = to_string(res);
	}
	system("PAUSE");
	return 0;
}