It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input


7 2 2 1 1 2 2 1 1


Sample Output


6


解题思路:

牛的选择分为两种情况,走与不走。

Apple Catching POJ - 2385 (DP)_递推

首先判断当前位置在当前秒会不会掉落苹果,如果当前秒有苹果掉落,那么当前状态+1

然后是走与不走的选择,取最大值,递推关系为:sDp[i][j] = max(sDp[i][j - 1], sDp[i - 1][j]);

#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;
const int MAXW = 35;
const int MAXT = 1010;
int w, t;
int sDp[MAXW][MAXT];  //状态递推集合
int treeSqu[MAXT];
int main() {
	memset(sDp, 0, sizeof(sDp));  //清0操作
	cin >> t >> w;
	for (int i = 0; i < t; ++i) {
		cin >> treeSqu[i];
	}
	//初始位置:树1
	for (int i = 0; i < t; ++i) { //树1位置开始递推
		if (treeSqu[i] % 2 == 1) {
			sDp[0][i]++;
		}
		if (i > 0) sDp[0][i] += sDp[0][i - 1]; //递推上一层
	}
	//开始动态规划
	for (int i = 1; i <= w; ++i) {   //秒数从0开始,步数从1开始,0是初始态
		for (int j = 0; j < t; ++j) {
			if (j == 0) {
				sDp[i][j] = sDp[i - 1][j];  //从上方递推
				if (treeSqu[j] % 2 != i % 2) {   //表示哪一棵树掉落
					sDp[i][j]++;  //加一
				}
			}
			else {
				sDp[i][j] = max(sDp[i][j - 1], sDp[i - 1][j]);  //走(左)和不走(右)
				if (treeSqu[j] % 2 != i % 2) {   //表示哪一棵树掉落
					sDp[i][j]++;  //加一
				}
			}
		}
	}
	cout << sDp[w][t - 1] << endl;
	system("PAUSE");
	return 0;
}