On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.
Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.
Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest
we know that the keys i
and e
might be stucked, but s
is not even though it appears repeatedly sometimes. The original string could be this isss a teest
.
Input Specification:
Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _
. It is guaranteed that the string is non-empty.
Output Specification:
For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.
Sample Input:
3
caseee1__thiiis_iiisss_a_teeeeeest
Sample Output:
ei
case1__this_isss_a_teest
解题思路:
要注意下面这些情况,比如 3 aabbaaa不存在坏键
3 aaabbaa也不存在坏键 ,用键码出现次数%K去判断
#include <iostream>
#include <map>
#include <vector>
#include <algorithm>
#include <string>
using namespace std;
int isBroken[128];
int K;
string inputs;
vector<char> detectedAlpha;
vector<char> sureBroken;
map<char, int> appearTimes;
int main() {
fill(isBroken, isBroken + 128, -2);
cin >> K;
cin >> inputs;
for (int i = 0; i < inputs.length(); ++i) {
if (!appearTimes[inputs[i]]) { //用于二次判断
appearTimes[inputs[i]] = 1;
}
else {
appearTimes[inputs[i]]++;
}
char curChar = inputs[i];
int appearTimes = 1;
for (int j = 1; i + j < inputs.length(); j++) {
if (inputs[i + j] != curChar) break;
else {
appearTimes++;
}
}
if (appearTimes % K == 0) { //-2表示未知状态
if (isBroken[(int)inputs[i]] == -2) {
detectedAlpha.push_back(inputs[i]);
isBroken[(int)inputs[i]] = -1; //-1表示损坏
}
}
else {
if (isBroken[(int)inputs[i]] == -2) {
isBroken[(int)inputs[i]] = 1; //1表示正常
}
}
}
//二次判断
for (auto itr = detectedAlpha.begin(); itr != detectedAlpha.end(); ++itr) {
if (appearTimes[*itr] % K == 0) { //依然正常
sureBroken.push_back(*itr);
}
else {
isBroken[(int)*itr] = 1;
}
}
//按顺序输出
for (auto x : sureBroken) {
printf("%c", x);
}
cout << endl;
//输出字符
int ind = 0;
for (; ind < inputs.length();) {
printf("%c", inputs[ind]);
if (isBroken[(int)inputs[ind]] == -1) {
ind += K;
}
else {
ind++;
}
}
system("PAUSE");
return 0;
}