Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivitymatrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input


4 0 4 9 21 4 0 8 17 9 8 0 16 21 17 16 0


Sample Output


28


解题思路:

最小生成树模板题,这里我使用prim算法进行解决,套用模板即可

#include <iostream>
#include <algorithm>
#include <string.h>
#include <vector>
#include <queue>
#include <stdio.h>
using namespace std;
const int MAXN = 310;  //农场数量最多300
const int INF = 0x3fffffff;
int N;   //N代表农场的数量
int stcost[MAXN][MAXN];
int minCosts[MAXN]; //结点到树的最小距离
bool isused[MAXN];  

int main() {
	while (scanf("%d",&N) != EOF) {
		for (int i = 0; i < N; ++i) {
			for (int j = 0; j < N; ++j) {
				scanf("%d", &stcost[i][j]);
			}
		}
		//先进行初始化
		for (int i = 0; i < N; ++i) {
			minCosts[i] = INF;
			isused[i] = false;  //设置为未访问
		}
		int minSum = 0;  //边权的最小值
		minCosts[0] = 0;
		while (true) {
			int v = -1;
			for (int u = 0; u < N; ++u) {  //挑选一个距离树最近的结点加入到集合中
				if (!isused[u] && (v == -1 || minCosts[u] < minCosts[v])) {  //v==-1表示第一种情况
					v = u;
				}
			}
			if (v == -1) break;  //如果所有结点都在集合中,则表示遍历完毕
			//将这个结点加入到集合中
			isused[v] = true;
			minSum += minCosts[v];  //加上边权

			for (int u = 0; u < N; ++u) {  //更新边权
				minCosts[u] = min(minCosts[u], stcost[v][u]);
			}
		}
		cout << minSum << endl;
	}

	system("PAUSE");
	return 0;
}