The Famous ICPC Team Again


Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1232    Accepted Submission(s): 602



Problem Description


When Mr. B, Mr. G and Mr. M were preparing for the 2012 ACM-ICPC World Final Contest, Mr. B had collected a large set of contest problems for their daily training. When they decided to take training, Mr. B would choose one of them from the problem set. All the problems in the problem set had been sorted by their time of publish. Each time Prof. S, their coach, would tell them to choose one problem published within a particular time interval. That is to say, if problems had been sorted in a line, each time they would choose one of them from a specified segment of the line.

Moreover, when collecting the problems, Mr. B had also known an estimation of each problem’s difficultness. When he was asked to choose a problem, if he chose the easiest one, Mr. G would complain that “Hey, what a trivial problem!”; if he chose the hardest one, Mr. M would grumble that it took too much time to finish it. To address this dilemma, Mr. B decided to take the one with the medium difficulty. Therefore, he needed a way to know the median number in the given interval of the sequence.


 



Input


For each test case, the first line contains a single integer n (1 <= n <= 100,000) indicating the total number of problems. The second line contains n integers xi (0 <= xi <= 1,000,000,000), separated by single space, denoting the difficultness of each problem, already sorted by publish time. The next line contains a single integer m (1 <= m <= 100,000), specifying number of queries. Then m lines follow, each line contains a pair of integers, A and B (1 <= A <= B <= n), denoting that Mr. B needed to choose a problem between positions A and B (inclusively, positions are counted from 1). It is guaranteed that the number of items between A and B is odd.


 



Output


For each query, output a single line containing an integer that denotes the difficultness of the problem that Mr. B should choose.


 



Sample Input


5 5 3 2 4 1 3 1 3 2 4 3 5 5 10 6 4 8 2 3 1 3 2 4 3 5


 



Sample Output


Case 1: 3 3 2 Case 2: 6 6 4


 


大体题意:


给你n个数,并且给你一个区间,求区间中 中间大的数。


思路:


把所有的数存到划分树中,进行查找第mid大的即可!


注意 mid = (nr - nl )/ 2+ 1;



划分树适合解决的题目:


求指定区间的第K大的数值!


#include<stdio.h> 
#include<algorithm> 
using namespace std; 
const int M = 100000 + 5; 
int tree[20][M],sorted[M]; 
int toLeft[20][M]; 
void build(int level,int left,int right){ 
    if(left==right)return ; 
    int mid=(left+right)>>1; 
    int i; 
    int suppose;
    suppose=mid-left+1; 
    for(i=left;i<=right;i++){ 
        if(tree[level][i]<sorted[mid]){ 
            suppose--; 
        } 
    } 
    int lpos=left,rpos=mid+1; 
    for(i=left;i<=right;i++){ 
        if(i==left){
            toLeft[level][i]=0; 
        }else{ 
            toLeft[level][i]=toLeft[level][i-1]; 
        } 
        if(tree[level][i]<sorted[mid]){
            toLeft[level][i]++; 
            tree[level+1][lpos++]=tree[level][i]; 
        }else if(tree[level][i]>sorted[mid]){
            tree[level+1][rpos++]=tree[level][i]; 
        }else{
            if(suppose!=0){
                suppose--; 
                toLeft[level][i]++; 
                tree[level+1][lpos++]=tree[level][i]; 
            }else{
                tree[level+1][rpos++]=tree[level][i]; 
            } 
        } 
    } 
    build(level+1,left,mid); 
    build(level+1,mid+1,right); 
} 

int query(int level,int left,int right,int qleft,int qright,int k){ 
    if( qleft==qright) 
        return tree[level][qleft]; 
    int s;
    int ss;
    int mid=(left+right)>>1; 
    if(left==qleft){ 
        s=0; 
        ss=toLeft[level][qright]; 
    }else{ 
        s=toLeft[level][qleft-1]; 
        ss=toLeft[level][qright]-s; 
    } 
    int newl,newr; 
    if(k<=ss){
        newl=left+s; 
        newr=left+s+ss-1; 
        return query(level+1,left,mid,newl,newr,k); 
    }else{
        newl=mid-left+1+qleft-s; 
        newr=mid-left+1+qright-s-ss; 
        return query(level+1,mid+1,right,newl, newr,k - ss); 
    } 
} 
int main(){
	int n,cnt=0;
	while(scanf("%d",&n) == 1){
		for (int i = 1; i <= n; ++i){
			scanf("%d",&tree[0][i]);
			sorted[i] = tree[0][i];
		}
		sort(sorted+1,sorted+n+1);
		build(0,1,n);
		int k;
		scanf("%d",&k);
		printf("Case %d:\n",++cnt);
		while(k--){
			int nl,nr;
			scanf("%d%d",&nl,&nr);
			int mid = (nr-nl)/2+1;
			printf("%d\n",query(0,1,n,nl,nr,mid));
		}
	}
	return 0;
}