Number Sequence



Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)


Total Submission(s): 113360 Accepted Submission(s): 27537




Problem Description


A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).





Input


The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.





Output


For each test case, print the value of f(n) on a single line.





Sample Input


1 1 3 1 2 10 0 0 0





Sample Output


2 5




解题思路:可以先打表,找出规律。


源代码:


#include <stdio.h>
#include <stdlib.h>

int f[50]={0,1,1};
void fac(int a,int b,int n)
{
  int i;
  for(i=3;i<=48;i++)
    f[i]=(a*f[i - 1] + b*f[i - 2])%7;  
  printf("%d\n",f[n]);
}

int main()
{
  int a,b,n;
  while(scanf("%d%d%d",&a,&b,&n) && a||b||n)
  {
    fac(a,b,n%48);                            
  }
  system("pause");
  return 0;    
}