Build The Electric System



In last winter, there was a big snow storm in South China. The electric system was damaged seriously. Lots of power lines were broken and lots of villages lost contact with the main power grid. The government wants to reconstruct the electric system as soon as possible. So, as a professional programmer, you are asked to write a program to calculate the minimum cost to reconstruct the power lines to make sure there's at least one way between every two villages.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 50) which is the number of test cases. And it will be followed by T consecutive test cases.

In each test case, the first line contains two positive integers N and E (2 <= N <= 500, N <= E <= N * (N - 1) / 2), representing the number of the villages and the number of the original power lines between villages. There follow E lines, and each of them contains three integers, ABK (0 <= AB < N, 0 <= K < 1000). A and Brespectively means the index of the starting village and ending village of the power line. If K is 0, it means this line still works fine after the snow storm. If K is a positive integer, it means this line will cost K to reconstruct. There will be at most one line between any two villages, and there will not be any line from one village to itself.

Output

For each test case in the input, there's only one line that contains the minimum cost to recover the electric system to make sure that there's at least one way between every two villages.

Sample Input

1
3 3
0 1 5
0 2 0
1 2 9

Sample Output

5
分析:一开始按照花费从小到大将路线排序,然后再来一次并查集整合所有线路,知道全部连通源代码:#include <iostream>
#include <algorithm>
using namespace std;
struct node
{
	int s,e,c;
}ss[40005];
int father[600],ans;
int cmp(struct node x,struct node y)  
{  
    return x.c<y.c;  
}
void init(int n)
{
	int i;
	for(i=0;i<n;i++)
	{
		father[i]=i;
	}
}
int Find_Set(int x)
{
	if(x!=father[x])
	  return Find_Set(father[x]);
	return father[x];
}
void Union_Set(struct node st)
{
	int x,y;
	x=Find_Set(st.s);
	y=Find_Set(st.e);
	if(x==y)  return ;
    if(x!=y)
    {
    	ans+=st.c;
    	father[x]=y;
	}
}
int main()
{
	int t,n,m,i;
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		for(i=0;i<m;i++)
		  cin>>ss[i].s>>ss[i].e>>ss[i].c;
		init(n);
		sort(ss,ss+m,cmp);	    
		ans=0;
		for(i=0;i<m;i++)
		{
			Union_Set(ss[i]);
		}
		cout<<ans<<endl;
	}
	return 0;
}