三角形


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51480 Accepted Submission(s): 17197



Problem Description


给定三条边,请你判断一下能不能组成一个三角形。





Input


输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;





Output


对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。





Sample Input


2 1 2 3 2 2 2





Sample Output


NO YES




源代码:

#include <stdio.h>
#include <stdlib.h>

int main()
{
  int m;
  float a,b,c;
  scanf("%d",&m);
  while(m--)
  {
    scanf("%f%f%f",&a,&b,&c);
    if(a+b>c && a+c>b && b+c>a)  
      printf("YES\n");
    else
      printf("NO\n");          
  }
  system("pause");
  return 0;    
}