SW1
Switch>en
Switch#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int f0/1
Switch(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode. --发现代码报错:在思科的三层交换机里,trunk端口的设置需要先封装,再设置为trunk端口
Switch(config-if)#switchport trunk encapsulation dot1q --封装
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all
【二层交换机不需要封装,但三层交换机需要封装】
【shift+? 命令帮助】
【table可以命令补全】
【目标--不同的部门获取到不同的ip地址】
【过程--1.创建vlan,通过不同的vlan将每一个部门进行逻辑划分;2.结合vlan对交换机端口模式的设置access+trunk;3.在三层交换机里设置默认网关地址;4.在三层交换机里设置三个地址池给三个不同的部门】
Switch(config-if)#hostname dsw
dsw(config)#vlan 10
dsw(config-vlan)#name jishubu
dsw(config-vlan)#exit
dsw(config)#vlan 20
dsw(config-vlan)#name caiwubu
dsw(config-vlan)#exit
dsw(config)#vlan 30
dsw(config-vlan)#name shichangbu
dsw(config-vlan)#exit
dsw(config)#int vlan 10
dsw(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
dsw(config-if)#ip address 192.168.10.254 255.255.255.0
dsw(config-if)#no shutdown
dsw(config-if)#exit
dsw(config)#int vlan 20
dsw(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
dsw(config-if)#ip address 192.168.20.254 255.255.255.0
dsw(config-if)#no shutdown
dsw(config-if)#exit
dsw(config)#int vlan 30
dsw(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up
dsw(config-if)#ip address 192.168.30.254 255.255.255.0
dsw(config-if)#no shutdown
dsw(config-if)#exit
dsw#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/1 unassigned YES unset up up
……….
Vlan1 192.168.1.1 YES manual up up
Vlan10 192.168.10.254 YES manual up up
Vlan20 192.168.20.254 YES manual up up
Vlan30 192.168.30.254 YES manual up up --up可以看到我们的端口已经尽数打开【网关地址设置成功】 双up即打开,一个up一个down是没有打开
【接下来在三层交换机里设置三个地址池给三个不同的部门】
【可以将上面的地址池命令段取出,编辑修改为我们需要的命令,可快速创建地址池】
Switch>
Switch>en
Switch#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname sw1 --为本台交换机重命名为sw1(修改设备名称)
sw1(config)# --可以看到已经重命名成功
sw1(config)#vlan 10 --创建vlan10(vlan即虚拟局域网)
sw1(config-vlan)#name jishubu --为vlan10命名为技术部jishubu
sw1(config-vlan)#exit
sw1(config)#vlan 20
sw1(config-vlan)#name caiwubu
sw1(config-vlan)#exit
sw1(config)#vlan 30
sw1(config-vlan)#name shichangbu
sw1(config-vlan)#exit
【基于端口划分vlan】
sw1(config)#interface range f0/2-3 --同时进入f0-2和f0-3端口,如果只进入一个端口的话(如进入端口f0/2)输入命令 interface f0/2
sw1(config-if-range)#switchport mode access --端口模式设置为access(access模式即接入模式,因为该端口连接终端设备,所以需要设置为access模式)
【补充-端口模式:
access:接入模式。只能允许一种的vlan流量通过
trunk:中继模式(主干模式)。可允许多种的vlan流量通过】
sw1(config-if-range)#switchport access vlan 10 --将端口f0-2、f0-3划分到vlan10
//对二层交换机进行配置VLAN 10 /VLAN 20
Switch>
Switch>en
Switch#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname sw1 --为本台交换机重命名为sw1(修改设备名称)
sw1(config)# --可以看到已经重命名成功
sw1(config)#vlan 10 --创建vlan10(vlan即虚拟局域网)
sw1(config-vlan)#name jishubu --为vlan10命名为技术部jishubu
sw1(config-vlan)#exit
sw1(config)#vlan 20
sw1(config-vlan)#name caiwubu
sw1(config-vlan)#exit
sw1(config)#vlan 30
sw1(config-vlan)#name shichangbu
sw1(config-vlan)#exit
【基于端口划分vlan】
sw1(config)#interface range f0/2-3 --同时进入f0-2和f0-3端口,如果只进入一个端口的话(如进入端口f0/2)输入命令 interface f0/2
sw1(config-if-range)#switchport mode access --端口模式设置为access(access模式即接入模式,因为该端口连接终端设备,所以需要设置为access模式)
【补充-端口模式:
access:接入模式。只能允许一种的vlan流量通过
trunk:中继模式(主干模式)。可允许多种的vlan流量通过】
sw1(config-if-range)#switchport access vlan 10 --将端口f0-2、f0-3划分到vlan10S
//配置三层交换机
Switch>en
Switch#vl da
Switch(vlan)#vl 10
Switch(vlan)#vl 20
Switch(vlan)#exit
Switch#conf t
Switch(config)#ip routing
Switch(config)#in vl 10
ip ad 192.168.30.1 255.255.255.0
Switch(config-if)#no sh
Switch(config-if)#exit
Switch(config)#in vl 20
Switch(config-if)#ip ad 192.168.40.1 255.255.255.0
Switch(config-if)#no sh
Switch(config-if)#exit
Switch(config)#in f0/24
Switch(config-if)#sw tr al vl 10,20
Switch(config-if)#end
Switch#sh ru
Switch#en
Switch#conf t
Switch(config)#ip dhcp excluded-address 192.168.30.1 //DHCP地址池做排除
Switch(config)#ip dhcp excluded-address 192.168.40.1
Switch(config)#in vl 10
Switch(config-if)#ip routing
Switch(config)#ip dhcp pool 10 //创建VLAN10的DHCP地址池
Switch(dhcp-config)#network 192.168.30.0 255.255.255.0 //设置DHCP地址池网段
Switch(dhcp-config)#default-router 192.168.30.1 //设置默认网关地址
Switch(dhcp-config)#dns-server 202.100.192.68 //设置默认DNS地址
Switch(dhcp-config)#exit
Switch(config)#in vl 20
Switch(config-if)#ip routing
Switch(config)#ip dhcp pool 20
Switch(dhcp-config)#network 192.168.40.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.40.1 //设置默认网关地址
Switch(dhcp-config)#dns-server 202.100.192.68 //设置默认DNS地址
Switch(dhcp-config)#exit
Switch(config)#end
Switch#sh ru