use ssh client to login into my Mac Min server without GUI. How can I tell what version of Mac OS X operating system am I using command prompt? How do I find out Mac OS X version from Terminal app bash shell?


On Apple Mac OS X you need to use the following command to find out operating system version:

  1. system_profiler
  2. sw_vers
  3. uname

Determine OS X version from the command line

Open the terminal app and type the following command:

$ sw_vers

Sample outputs:

Fig. 01: Find OS X version from the command line


Where, you can pass the following options:

  1. -productName
  2. -productVersion
  3. -buildVersion

Say hello to system_profiler

You can use the system_profiler command as follows to get the same information:

$ system_profiler | less
$ system_profiler SPSoftwareDataType

Sample outputs:

Fig.02: Tell what version of OS X you are using on from the command line

Using SystemVersion.plist file

/System/Library/CoreServices/SystemVersion.plist file. One can print the version info as follows:

$ cat /System/Library/CoreServices/SystemVersion.plist

Sample outputs:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>ProductBuildVersion</key>
	<string>15B42</string>
	<key>ProductCopyright</key>
	<string>1983-2015 Apple Inc.</string>
	<key>ProductName</key>
	<string>Mac OS X</string>
	<key>ProductUserVisibleVersion</key>
	<string>10.11.1</string>
	<key>ProductVersion</key>
	<string>10.11.1</string>
</dict>
</plist>


On Mac OS X server, try:

$ cat /System/Library/CoreServices/ServerVersion.plist

How do I find out OS X Darwin kernel version?

Simply type the following uname command to see operating system name including the machine hardware name, the nodename, the machine processor architecture name, the operating system release, the operating system name, and the operating system version:

$ uname -av

Sample outputs:

Darwin Viveks-MacBook-Pro.local 15.0.0 Darwin Kernel Version 15.0.0: Sat Sep 19 15:53:46 PDT 2015; root:xnu-3247.10.11~1/RELEASE_X86_64 x86_64

Tip: Read OS X version in audio format

Type the following bash command to hear OS X version using the say command on OS X:


say $(sw_vers) 
say $(sw_vers -productName && sw_vers -productVersion | sed 's/10//')