Bone Collector


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 40132    Accepted Submission(s): 16661



Problem Description


Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?




Bone Collector   2602 (01背包)(模板)_Java



 



Input


The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.


 



Output


One integer per line representing the maximum of the total value (this number will be less than 2 31).


 



Sample Input


1
5 10
1 2 3 4 5
5 4 3 2 1


 


Sample Output


14


 


//简单的01背包 
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
struct zz
{
	int val,v;
}q[2100];
int cmp(zz a,zz b)
{
	if(a.val==b.val)
		return a.v<b.v;
	return a.val>b.val;
}
int dp[1100];
int main()
{
	int t,n,m,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			scanf("%d",&q[i].val);
		for(i=0;i<n;i++)
			scanf("%d",&q[i].v);
		sort(q,q+n,cmp);
		memset(dp,0,sizeof(dp));
		for(i=0;i<n;i++)
		{
			for(j=m;j>=q[i].v;j--)
			{
				dp[j]=max(dp[j],dp[j-q[i].v]+q[i].val);
			}
		}
		printf("%d\n",dp[m]);
	}
}
<pre class="cpp" name="code">#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main(){
	int i,j,k,t,n,m,v;
	int dp[1010],c[1010],w[1010];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&v);
		for(i=1;i<=n;i++)
			scanf("%d",&w[i]);
		for(i=1;i<=n;i++)
			scanf("%d",&c[i]);
			memset(dp,0,sizeof(dp));
			for(i=1;i<=n;i++)
			{
				for(j=v;j>=c[i];j--)
				{
					dp[j]=max(dp[j-c[i]]+w[i],dp[j]);
				}
			}
			printf("%d\n",dp[v]);
	}
	return 0;
}



#include<stdio.h>
#include<string.h>
#include<math.h>
#define max(a,b) a>b?a:b 
int v[1010],w[1010];
int sum[1010];
int main(){
	int t;
	int n,m;
	int i,j;
	scanf("%d",&t);
	while(t--)
	{
		memset(sum,0,sizeof(sum));
		memset(v,0,sizeof(v));
		memset(w,0,sizeof(w));
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			scanf("%d",&w[i]);
		for(i=0;i<n;i++)
			scanf("%d",&v[i]);
		for(i=0;i<n;i++)
		{
			for(j=m;j>=v[i];j--)
			{
				sum[j]=max(sum[j],sum[j-v[i]]+w[i]);
			}
		} 
		printf("%d\n",sum[m]);
	}
	return 0;
}