区域赛系列一多边形划分


1000 ms  |           内存限制: 65535

难度:2

Give you a convex(凸边形), diagonal n-3 disjoint divided into n-2 triangles(直线), for different number of methods, such as n=5, there are 5 kinds of partition method, as shown in Figure

The first line of the input is a n (1<=n<=1000), expressed n data set.

The next n lines each behavior an integer m (3<=m<=18), namely the convex edges.

输出 For each give m,, output how many classification methods.

example output: Case #a : b

样例输入

3345


样例输出

Case #1 : 1


Case #2 : 2


Case #3 : 5

//题意:


给你一个有 n条边的凸边形,让你用n-3条直线见他分成n-2个三角形,问有几种分法。


#include<stdio.h>
#include<string.h>
int main()
{
	int a[20];
	int t,T=1,n,i,j,b;
	a[2]=a[3]=1;
	for(i=3;i<20;i++)
	{
		a[i]=0;
		b=i-1;
		for(j=2;j<i;j++)
		{
			a[i]+=a[j]*a[b];
			b--;
		}
	}
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		printf("Case #%d : %d\n",T++,a[n]);
	}
	return 0;
}