Max Sum


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 177961    Accepted Submission(s): 41505



Problem Description


Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.


 



Input


The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).


 



Output


For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.


 



Sample Input


2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 


Sample Output


Case 1:
14 1 4

Case 2:
7 1 6

 


搜索


C语言程序代码

#include<stdio.h>
 #include<string.h>
 int a[100010];
 int main(){
  int t,cnt=1;
  scanf("%d",&t);
  while(t--)
  {
   int st,ed,x,y,sum,sumn;
   st=ed=x=y=1;
   int n,i;
   scanf("%d",&n);
   for(i=1;i<=n;i++)
    scanf("%d",&a[i]);
   sum=0;sumn=a[1];
   for(i=1;i<=n;i++)
   {
    sum+=a[i];
    if(sum>sumn)//通过比较更新最大和,与起点和终点。 
    {
     sumn=sum;
     st=x;ed=i;
    }
    if(sum<0)
    {
     x=i+1;
     sum=0;
    }
   }
   printf("Case %d:\n",cnt++);
   printf("%d %d %d\n",sumn,st,ed);
   if(t)
    printf("\n");
  }
  return 0;
 }