Palindrome

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 72   Accepted Submission(s) : 19


Problem Description


A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.


 


 


Input


Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.


 


 


Output


Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.


 


 


Sample Input


5 Ab3bd


 


 


Sample Output


2


/*
解题思路::
		要求的是加几个字母组成回文字符串,首先将其翻转,存入一新数组中
		用LCS计算其最长公共子序列,再用字符长度减去最长公共子序列即为所求。 

*/
#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
char a[5010],b[5010];
int p[2][5010];
int main(){
	int i,j,n;
	while(scanf("%d",&n)!=EOF)
	{		
		scanf("%s",a);
		for(i=n-1,j=0;i>=0;i--)
			b[j++]=a[i];
		memset(p,0,sizeof(p));
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				
				if(a[i-1]==b[j-1])
					p[i%2][j]=p[(i-1)%2][j-1]+1;
				else
					p[i%2][j]=max(p[(i-1)%2][j],p[i%2][j-1]);
			}
			printf("%d\n",n-p[n%2][n]);
	}
	return 0;
}