Wormholes


Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 36832

 

Accepted: 13494


Description


While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.


Input


Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.


Output


Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).


Sample Input


2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8


Sample Output


NO YES


 


#include<string.h>
#include<stdio.h>
#include<queue>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int n,m,t;
struct Edge
{
	int from,to,val,next;
}edge[5100];
int head[600],edgenum;
void add(int u,int v,int w)
{
	Edge E={u,v,w,head[u]};
	edge[edgenum]=E;
	head[u]=edgenum++;
}
int dis[600],vis[600],used[600];
void SPFA(int x)
{
	queue<int>q;
	memset(vis,0,sizeof(vis));
	memset(dis,INF,sizeof(dis));
	memset(used,0,sizeof(used));
	q.push(x);
	dis[x]=0;
	vis[x]=1;
	used[x]++;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=0;
		for(int i=head[u];i!=-1;i=edge[i].next)
		{
			int v=edge[i].to;
			if(dis[v]>dis[u]+edge[i].val)
			{
				dis[v]=dis[u]+edge[i].val;
				if(!vis[v])
				{
					vis[v]=1;
					used[v]++;
					if(used[v]>n)
					{
						printf("YES\n");
						return ;
					}
					q.push(v);
				}
			}
		}
	}
	printf("NO\n");
}
int main()
{
	int T,a,b,c;
	scanf("%d",&T);
	while(T--)
	{
		memset(head,-1,sizeof(head));
		edgenum=0;
		scanf("%d%d%d",&n,&m,&t);
		while(m--)
		{
			scanf("%d%d%d",&a,&b,&c);
			add(a,b,c);
			add(b,a,c);
		}
		while(t--)
		{
			scanf("%d%d%d",&a,&b,&c);
			add(a,b,-c);
		}
		SPFA(1);
	}
	return 0;
}