A Simple Problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4910 Accepted Submission(s): 1254
Problem Description
For a given positive integer n, please find the smallest positive integer x that we can find an integer y such that y^2 = n +x^2.
Input
The first line is an integer T, which is the the number of cases.
Then T line followed each containing an integer n (1<=n <= 10^9).
Output
For each integer n, please print output the x in a single line, if x does not exit , print -1 instead.
Sample Input
2 2 3
Sample Output
-1 1
//将方程变换为:y^2-x^2=n;
=>(y-x)*(y+x)=n;
所以枚举所有的(y-x)然后不断更新最小值。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int main()
{
int t,n,i;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
int ans=INF;
for(i=1;i<=sqrt(n);i++)
{
if(n%i==0)
{
int a=i;
int b=n/i;
if(b-a>0&&(b-a)%2==0)
{
int x=(b-a)/2;
if(x<ans)
ans=x;
}
}
}
if(ans==INF)
printf("-1\n");
else
printf("%d\n",ans);
}
return 0;
}