ZOJ Problem Set - 2562


More Divisors


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Everybody knows that we use decimal notation, i.e. the base of our notation is 10. Historians say that it is so because men have ten fingers. Maybe they are right. However, this is often not very convenient, ten has only four divisors -- 1, 2, 5 and 10. Thus, fractions like 1/3, 1/4 or 1/6 have inconvenient decimal representation. In this sense the notation with base 12, 24, or even 60 would be much more convenient.

The main reason for it is that the number of divisors of these numbers is much greater -- 6, 8 and 12 respectively. A good quiestion is: what is the number not exceeding n that has the greatest possible number of divisors? This is the question you have to answer.

Input:

The input consists of several test cases, each test case contains a integer n (1 <= n <= 1016).

Output:

For each test case, output positive integer number that does not exceed n and has the greatest possible number of divisors in a line. If there are several such numbers, output the smallest one.


Sample Input:


10 20 100


Sample Output:


6 12 60



 



#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef unsigned long long ll;
const ll INF = (ll)1<<63;
ll n;
ll ans;
int m;
int p[16]={2,3,5,7,11,13,17,19,23,29,31,37,41,43,47,53};
void dfs(int gen,ll tmp,int num)
{
	if(gen>=16)
		return ;
	if(num>m)
	{
		m=num;
		ans=tmp;
	}
	if(num==m&&ans>tmp)
		ans=tmp;
	for(int i=1;i<=63;i++)
	{
		if(n/p[gen]<tmp)
			break;
		dfs(gen+1,tmp*=p[gen],num*(i+1));
	}
}
int main()
{
	while(scanf("%lld",&n)!=EOF)
	{
		ans=INF;
		m=0;
		dfs(0,1,1);
		printf("%lld\n",ans);
	}
	return 0;
}