The Euler function


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4743    Accepted Submission(s): 1983



Problem Description


The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)




Input


There are several test cases. Each line has two integers a, b (2<a<b<3000000).




Output


Output the result of (a)+ (a+1)+....+ (b)




Sample Input

3 100


Sample Output


3042


#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 3000010
#define ll long long
using namespace std;
ll a[N];
ll eular()
{
	int i,j;
	memset(a,0,sizeof(a));
	a[1]=1;
	for(i=2;i<N;i++)
	{
		if(!a[i])
		{
			for(j=i;j<N;j+=i)
			{
				if(!a[j])
					a[j]=j;
				a[j]=a[j]/i*(i-1);
			}
		}
	}
	for(i=2;i<N;i++)
		a[i]+=a[i-1];
}
int main()
{
	int l,r;
	eular();
	while(scanf("%d%d",&l,&r)!=EOF)
	{
		printf("%I64d\n",a[r]-a[l-1]);
	}
	return 0;
}