Dating with girls(2)


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2645    Accepted Submission(s): 736



Problem Description


If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!

The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.


There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.


hdoj  Dating with girls(2)  2579  (BFS++判断) 好题_Java




Input


The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.




Output


For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".




Sample Input


1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.




Sample Output


7


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
char a[110][110];
int b[110][110][12];
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
int n,m,t;
struct zz
{
	int x;
	int y;
	int l;
}f1,f2;
void bfs(int x,int y)
{
	memset(b,0,sizeof(b));
	queue<zz>q;
	f1.x=x;f1.y=y;f1.l=0;
	q.push(f1);
	while(!q.empty())
	{
		f1=q.front();
		q.pop();
		if(a[f1.x][f1.y]=='G')
		{
			printf("%d\n",f1.l);
			return ;
		}
		for(int i=0;i<4;i++)
		{
			f2.x=dx[i]+f1.x;
			f2.y=dy[i]+f1.y;
			f2.l=f1.l+1;
			int d=f2.l%t;
			if(f2.x<=n&&f2.x>0&&f2.y<=m&&f2.y>0&&b[f2.x][f2.y][d]==0)
			{
				b[f2.x][f2.y][d]=1;
				if(a[f2.x][f2.y]=='#'&&d)
					continue;
					q.push(f2);
			}			
		}
	}
	printf("Please give me another chance!\n");
}
int main()
{
	int T;
	int i,j;
	int sx,sy;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d",&n,&m,&t);
		for(i=1;i<=n;i++)
			scanf("%s",a[i]+1);
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				if(a[i][j]=='Y')
				{
					sx=i;sy=j;
				}
			}
		}
		bfs(sx,sy);
	}
	return 0;
}