LightOJ - 1019


Brush (V)



Submit Status




Description




Tanvir returned home from the contest and got angry after seeing his room dusty. Who likes to see a dusty room after a brain storming programming contest? After checking a bit he found that there is no brush in him room. So, he called Atiq to get a brush. But as usual Atiq refused to come. So, Tanvir decided to go to Atiq's house.

The city they live in is divided by some junctions. The junctions are connected by two way roads. They live in different junctions. And they can go to one junction to other by using the roads only.

Now you are given the map of the city and the distances of the roads. You have to find the minimum distance Tanvir has to travel to reach Atiq's house.






Input




Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a blank line. The next line contains two integers N (2 ≤ N ≤ 100) and M (0 ≤ M ≤ 1000), means that there are N junctions and M two way roads. Each of the next M lines will contain three integers u v w (1 ≤ u, v ≤ N, w ≤ 1000), it means that there is a road between junction u and v and the distance is w. You can assume that Tanvir lives in the 1st junction and Atiq lives in the Nth junction. There can be multiple roads between same pair of junctions.






Output




For each case print the case number and the minimum distance Tanvir has to travel to reach Atiq's house. If it's impossible, then print 'Impossible'.






Sample Input




2

 

3 2

1 2 50

2 3 10

 

3 1

1 2 40






Sample Output




Case 1: 60

Case 2: Impossible

//题意:输入n, m

表示n座城市之间有m条路,问从1到n之间的最短路

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int n,m;
int dis[1010],vis[1010],map[110][110];
void SPFA()
{
	memset(vis,0,sizeof(vis));
	memset(dis,INF,sizeof(dis));
	for(int i=1;i<=n;i++)
	dis[i]=map[1][i];
	dis[1]=0;
	vis[1]=1;
	for(int i=2;i<=n;i++)
	{
		int Min=INF;
		int f=-1;
		for(int j=1;j<=n;j++)
		{
			if(!vis[j]&&Min>dis[j])
			{
				f=j;
				Min=dis[j];
			}
		}
		if(f==-1) break;
		vis[f]=1;
		for(int j=1;j<=n;j++)
		{
			if(dis[j]>dis[f]+map[f][j])
			{
				dis[j]=dis[f]+map[f][j];
			}
		}
	}
}
int main()
{
	int t,k=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		memset(map,INF,sizeof(map));
		int a,b,c;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c)
			map[a][b]=map[b][a]=c;
		}
		SPFA();
		printf("Case %d: ",k++);
		if(dis[n]!=INF)
			printf("%d\n",dis[n]);
		else
			printf("Impossible\n");
	}
	return 0;
}

 



Time Limit: 2000MS

Memory Limit: 32768KB

64bit IO Format: %lld & %llu