Billboard Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16256 Accepted Submission(s): 6877


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

Sample Input
3 5 5 2 4 3 3 3

Sample Output
1 2 1 3 -1
//题意:
//给一个h*w(高为h,宽为w)的广告栏,要在广告栏里贴广告,每个广告的长度为w[i],高度为1.
//优先贴在广告栏的左上角。如果没有空间贴广告,就输出-1,否则输出广告所贴的位置(第几行)
//思路,将广告栏颠倒,再将其看作为一个线段,但都有固定的高度 w .
//变换一下就是好做了。 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 200010
int h,w,t;
struct zz
{
	int l;
	int r;
	int m;
}q[4*N];
void build(int gen,int l,int r)
{
	q[gen].l=l;
	q[gen].r=r;
	q[gen].m=w;
	if(l==r)
		return ;
	int mid=(l+r)/2;
	build(gen<<1,l,mid);
	build(gen<<1|1,mid+1,r);
}
int update(int gen,int n)
{
	if(q[gen].l==q[gen].r)
	{
		q[gen].m-=n;
		return q[gen].l;
	}
	int cnt;
	if(q[gen<<1].m>=n)
		cnt=update(gen<<1,n);
	else
		cnt=update(gen<<1|1,n);
	q[gen].m=max(q[gen<<1].m,q[gen<<1|1].m);
	//为了下面判断是否还能再往里面贴广告条													
	return cnt;
}
int main()
{
	int n,i;
	while(scanf("%d%d%d",&h,&w,&t)!=EOF)
	{
		build(1,1,min(h,t));
		while(t--)
		{
			scanf("%d",&n);
			if(q[1].m<n)
				printf("-1\n");
			else
				printf("%d\n",update(1,n));
		}
	}
	return 0;
}